0

I installed Ubuntu on my Acer aspire f 15 laptop using option "erase the disk and install Ubuntu". it erased the entire disk and installed Ubuntu successfully. but when I restart,I sow the message "no bootable device". I entered bios to change the order of booting but Ubuntu name is not there to change its order! I tried boot-repair and it gave me the link and a message "please do not forget to make your BIOS boot on sdb1/EFI/ubuntu/shimx64.efi file!"

I don't know what does this message says and I don't know what action i should take.

note:Ubuntu is installed alone on my laptop.

any help is appreciated.

1

I also could not boot into my computer when I switched to UEFI. I fixed it by selecting "Boot from EFI File" in the BIOS and "Customized Boot" or something similar.

But I think it can be fixed if you put the EFI Partition to /boot/efi/. So in your case it should be in /boot/efi/EFI/ubuntu/shimx64.efi. It should then detect it normally.

5
  • how should i put the EFI partition to boot/efi/EFI/ubuntu/shimx64.efi? Should i do this in bios or on liveCD??? Jan 19 '18 at 9:32
  • You can change it in /etc/fstab. There should be a line similar to this one: UUID=AD9F-2F82 /boot/efi vfat rw,relatime,.... As you can see, my partition is mounted in /boot/efi. You just have to change that. You just need access to a terminal that can edit this file.
    – Sakkaku
    Jan 19 '18 at 11:09
  • will you please tell me the exact place I should go on liveCD or exact commands I should enter?? it's the first time I'm using ubuntu and I don't know much about it. Jan 19 '18 at 11:36
  • it says permission is denied when i entered /etc/fstab Jan 19 '18 at 11:41
  • I will add another anwser with the detailed steps. The comments might be too small.
    – Sakkaku
    Jan 19 '18 at 12:27
1

First boot into the LiveCD. And open a terminal and type sudo -i. Now you have permissions do everything.

Then you have to mount your partions to a folder. Type lsblk and search for the root partition of Ubuntu. It should be something with /dev/sdaX (X stands for any number, for example sda1).

Then type mount /dev/sdaX /mnt. /dev/sdaX should be the partition that you found with lsblk. Now the partition is mounted and you can edit the files.

Now type gedit /mnt/etc/fstab and you can change the path of the EFI partition (it should have a vfat in the line). Change it to /boot/efi. After that close it and type in a terminal umount /mnt/.

Reboot and it should work now.

5
  • I just saw your link from boot-repair. Your root partition is probably /dev/sdb2.
    – Sakkaku
    Jan 19 '18 at 12:42
  • 1
    Ok, I just tested it on my computer and changing fstab did not seem to change anything. You can still try it but if it does not work, try searching in your BIOS for something with "EFI File", "UEFI File" or something similar. You need to get your computer to boot from a EFI file. Sometimes you have to specify it manually by adding EFI/ubuntu/shimx64.efi somewhere.
    – Sakkaku
    Jan 19 '18 at 12:52
  • still permission denied for /dev/sdb2. thanks anyway Jan 19 '18 at 13:59
  • Did you find anything in your BIOS? Try setting your Supervisor password if available, then there might be an option with UEFI. Or try disabling secure boot.
    – Sakkaku
    Jan 19 '18 at 15:14
  • I installed ubuntu from Usb now. and repaired the boot. i had previously disabled secure boot Jan 19 '18 at 15:39
0

use this link if you had the same problem

image

0

For people still with this trouble, Hello, I also had similar problem with a Acer laptop. After searching on forum for solution I got the hint that the UEFI file is not found or not considered as 'trusted'. In my boot options (press F2 at start) I selected the UEFI file as trusted for executing from /HDDO/EFI/ubuntu/shimz64.efi' . Hopefully it solves your issue too.

0

Further to Piyush, this is also how I solved this problem on my Acer Aspire e5 575. I first had dual-boot for a couple of years, but then wanted to delete Windows and recover that partition. But after installing Ubuntu and formatting the HDD in the process, an error appeared at boot-up: "Default Boot Device Missing or Boot Failed", or "No Bootable Device", probably once the UEFI/BIOS has been cleared.

One therefore needs to fiddle in the UEFI (BIOS) configuration to make an Ubuntu-only installation bootable:

  1. Install Ubuntu (it worked with 18.04 and 20.04) from a USB drive.
  2. Enter UEFI (BIOS) with F2 once Acer appears
  3. Make sure a security management password is set, so to enable several of the functions, and that Secure Boot is enabled (initially, for same reason) in the Boot tab.
  4. In Security tab, execute "Restore Secure Boot to Factory Default", then reboot once more into UEFI/BIOS with F2
  5. Back to Security tab, enter "Select an UEFI as Trusted for Executing", HDD0 (or change if other drive), ../ Ubuntu / grub64x.efi, Yes.
  6. In Boot tab, disable Secure Boot
  7. F10 to save and exit.

Hopefully, this should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.