2

A recent kernel update seems to have drastically destabilised my laptop - a Dell Precision M3520. The device shows in lspci as:

02:00.0 Network controller [0280]: Intel Corporation Device [8086:24fd] (rev 78)  
  Subsystem: Intel Corporation Device [8086:0050]

It had been working fine for months, but over Xmas it began to freeze when used on wifi. From the logs I determined it was the wifi card and reinstalled the OS. Whilst this has made it stable again, it's now on the default 16.04 kernel 4.4.0-109, and the wifi card is not usable at all. I understand the card needs at least a 4.8 kernel to work, but my attempts to install a newer kernel haven't worked:

  • I've installed the HWE standard kernel (linux-signed-image-generic-hwe-16.04), which as of today is 4.13.0-26. As soon as the UI loads, Network-Manager lists no devices at all (including wired ethernet) available, and trying to sudo locks up the terminal. The OS stability degrades from there until the whole UI freezes and I have to hard-reboot the machine. Logs show CPU warnings from the kernel with the iwlwifi module consuming many seconds of CPU time without response.
  • I tried the latest available 4.8 kernel, 4.8.0-58, but this caused odd problems on the disk encryption screen - the password box did not focus and my password ended up visible in the corner of the screen, so I wasn't able to boot it up.
  • I have tried downloading the latest device firmware directly from Intel (iwlwifi-8265-22.ucode) with the HWE kernel but this made no difference.
  • I can't remember what kernel release I was on before the stability problems.

I do not really have the option to upgrade beyond 16.04 as it's a company laptop and our standard distro is LTS. I can't really wait for 18.04; is there any way to make this work while staying on 16.04, e.g. is there a known good kernel for this wifi card I can try?

  • As far as I am aware, every 4.8 and later kernel works well with Intel devices including the 8265. If you press the airplane mode button, disabling the wireless, does the stability instantly improve? Also, you might try blacklisting iwlwifi and rebooting. Is the stability restored? If not, then we suspect that iwlwifi is not the real problem. – chili555 Jan 18 '18 at 17:15
  • Thanks for your comment @chili555, I've read a few threads you've contributed to on the Ubuntu forums on the subject. I'll give this a try. – Gargravarr Jan 18 '18 at 17:33
  • @chili555 ah, I should have noticed - the M3520 does not have an explicit Airplane Mode button although it does have a hotkey to disable/enable all wireless devices; hopefully that will do the trick. – Gargravarr Jan 18 '18 at 17:34
  • @chili555 interesting. So I blacklisted iwlwifi and booted the 4.13 kernel; UI loaded stably and I was able to sudo. I then ran modprobe iwlwifi while watching kern.log and it worked as expected - wifi has been active and connected for several minutes now and no warnings from the kernel. Possibly a dependency being loaded in the wrong order? – Gargravarr Jan 19 '18 at 12:11
  • It could be possible, strange things happen. If it remains stable and in all respects usable, I will write an answer that loads the module very late in the process and we'll test. – chili555 Jan 19 '18 at 15:59

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.