0

I have the default installation of GIMP which comes with Ubuntu 16.0.4 LTS (2.8.22).

I'm a fan of launching programmes by pressing Super then typing the name: Launching Firefox from the launcher

But I've tried every combination of names for starting GIMP and the application is never found. I've tried gimp, GIMP, GNU, image.

Why does GIMP not show in the launcher?

  • Does ls /usr/share/applications/ | grep -i gimp outputs anything ? – N. Cornet Jan 18 '18 at 14:17
  • You may need to restart (or logout / login again), or, if it still does't show, try deleting cache as per here: Dash (from Unity) does not showing Applications. – JonasCz - Reinstate Monica Jan 18 '18 at 14:18
  • @N.Cornet No, that grep doesn't find anything. – LondonRob Jan 20 '18 at 16:27
  • 1
    Does gimp start from the command line? How did you install it? (gimp is not part of the default installation of Ubuntu.) In my Ubuntu 16.04 LTS I have gimp version 2.8.16-1ubuntu1.1, which is another version than yours. – sudodus Jan 20 '18 at 16:56
  • 1
    (2.8.22) is not the "default installation of GIMP " in 16.04 from a debian package. You most likely installed the snap version of gimp which could be behind not showing in the Dash. – doug Jan 20 '18 at 17:09
2

If as it appears you installed the snap version of gimp in 16.04 you won't find it in the Dash. This should allow it to appear

sudo apt install snapd-xdg-open Then try a log out/in, (may work) or a restart will definitely work

Also note that the snap version of gimp installed from the software manager will be confined. If you need it to open files from other partitions then remove the snap & re-install using the --classic option. Ex.

sudo snap remove gimp

sudo snap install gimp --classic

Note that there is little support for bugs with snaps, no launchpad bug reporting, ect. More like what you get installing apps from play stores like google's and apple's.

  • 1
    I've never heard of snap, but I must've installed GIMP from the Ubuntu Software Centre, which shows two versions, 2.8.16-1ubuntu1.1, and the 2.8.22 I had installed. Very confusing! Uninstalled the 2.8.22 and installed 2.8.16. Problem solved! Thanks. – LondonRob Jan 21 '18 at 12:38
0

You have to create a .desktop file for GIMP

Simply open a terminal and type

gedit ~/.local/share/applications/gimp.desktop

and paste this in the editor

[Desktop Entry]
Version=1.0
Type=Application
Name=GNU Image Manipulation Program
GenericName=Image Editor
Comment=Create images and edit photographs
Exec=/snap/bin/gimp
Icon=gimp
Terminal=false
Categories=Graphics;2DGraphics;RasterGraphics;GTK;
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=GIMP
X-GNOME-Bugzilla-Component=General
X-GNOME-Bugzilla-Version=2.8.20
X-GNOME-Bugzilla-OtherBinaries=gimp-2.8
StartupNotify=true
MimeType=image/bmp;image/g3fax;image/gif;image/x-fits;image/x-pcx;image/x-portable-anymap;image/x-portable-bitmap;image/x-portable-graymap;image/x-portable-pixmap;image/x-psd;image/x-sgi;image/x-tga;image/x-xbitmap;image/x-xwindowdump;image/x-xcf;image/x-compressed-xcf;image/x-gimp-gbr;image/x-gimp-pat;image/x-gimp-gih;image/tiff;image/jpeg;image/x-psp;application/postscript;image/png;image/x-icon;image/x-xpixmap;image/svg+xml;application/pdf;image/x-wmf;image/x-xcursor;
X-Ubuntu-Gettext-Domain=gimp20

Where /snap/bin/gimp after Exec= is the command that the 'icon' will run. In this case, according to a command, we assume that you installed the snap version of GIMP, if that is not the case, replace this line by

Exec=gimp-2.8

Save the file and exit the editor.

You'll need to log out and log back in.

  • 2
    sudo alone shouldn't be used with GUI programs, since it can mess with the ownership of files in your home directory (by making them owned by root). Instead, sudo -H should be used. – Chai T. Rex Jan 20 '18 at 17:00
  • If in fact he installed the snap version of gimp you'd need to adjust some parts of your .desktop file. I'd say it's 90+% likely that is what the op has. – doug Jan 20 '18 at 17:15
  • The Exec= line would need to be /snap/bin/gimp The TryExec the same or removed. Best place to save file would be ~/.local/share/applications & not as root. – doug Jan 20 '18 at 17:21
  • I updated my answer, but as you explain in your answer, if it was installed with snap, my answer isn't appropriated... – N. Cornet Jan 20 '18 at 17:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.