Since I installed Ubuntu 16.04 LTS, VLC 2.2.2 will systematically open video files in 2 separate windows: video in one, audio (equalizer sound bars) and controls in the other.

VLC is set as the default player, so I can simply click on files to summon vlc to open them (always in 2 separate windows, unfortunately). I made sure Tools > Preferences > Interface > Playlists and Instances were set to allow only one instance and one instance when started from file as suggested in other threads addressing trouble when opening several files at once, which is not my case.

This thread on Ubuntu Forums provides a workaround for the bug affecting 2009 versions of both Ubuntu and VLC, which likely won't apply to either in 2018 (I'll try if no more obvious fix is suggested). If this is just a "settings" problem, I don't know what it is, as VLC is pretty much unchanged from the default downloaded version. Any ideas?

  • 1
    Same problem in Manjaro, VLC version 3.0.16
    – Jesbus
    Aug 13, 2021 at 19:18

5 Answers 5


I have had the same problem on Ubuntu 21.04,21.10 deb version vlc.

I tried to change Video Output setting and also I change Input/Codecs -> Hardware-accelerated decoding setting, after that, it works fine.

I use the nvidia proprietary graphic driver, so I chose VDPAU output and VDPAU video decoder. You may have to choose the value according to your graphic driver.

Actually it was not 100% ok, but mostly(almost 99%) vlc open only one window after this setting.

vlc Preferences -> Video -> Output -> Specify your output

  • 1
    Choosing OpenGL in output also worked for me ;) Apr 4, 2022 at 19:48
  • it worked for me thakns. Apr 10, 2022 at 14:20

Strange thing: I tried playing several video files since the vlc purge/reinstall, and they came up in the dreaded dual-window style, but now with no sound.

I checked that audio was enabled in vlc (it was), and that at the system level, audio hadn't been set at 0, or muted (it hadn't).

So I did a search, and tried a proposed solution: reset preferences in vlc. I did, and noticed that Allow only one instance was now unchecked. I exited vlc, clicked on a video file, and bingo: a single window opens, with sound! I of course tried opening a bunch of random audio and video files to make sure this wasn't just a one-time occurrence, and they all now open as expected.

Not sure what resetting preferences achieved over reinstalling vlc, or if Allow only one instance being unchecked is instrumental, but it worked! Thanks to Robert Riedl for his time!

  • It would be useful if you did the experiment of checking "Allow only one instance again and seeing if it fixes things. (I am having a similar issue. It appears less consistent though so atlhough I tried both with and without "Allow only one instance" checked I haven't determined yet whether it fixes the issue.
    – Kvothe
    Dec 11, 2021 at 21:07

Adding the solution that worked for me. Note: I am on Ubuntu 20.04 and using VLC 3.0.16 Vetinari.

  1. Tools -> Preferences -> Audio
  2. Find Visualization
  3. Change to Automatic. Mine was set to None

This solved the problem of playing MKV files in 2 separate windows.

enter image description here


Remove and reinstall works for me.

sudo snap remove vlc

sudo apt-get install vlc

  • This is a slightly different form of "remove and reinstall" as you're removing the snap version of VLC and replacing it with a deb packaged version. Is this the solution you mean to offer?
    – matigo
    Mar 22, 2022 at 8:52

Go to Tools->Preferences and select "Interface Settings" and under "Playlist enter image description hereand Instances", you must to select "Allow only one instance" and "Use only one instance hen started from file manager".

After these two settings, the vlc will open only into a single window. Have fun.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .