0

I am struggling with making Virtualbox 5.2 work with 16.04 LTS. I've read everything posted on the topic here. The installation path that resulted in moving forward was via .deb package from Oracle website (and the respective extension pack manually added). I have the virtualbox manager GUI loading just fine. However, when I try to start a virtual machine, kernel-related error messages keep popping up. First, I had trouble with 'vboxdrv' and fixed it by signing kernel modules as suggested here Could not load 'vboxdrv' after upgrade to Ubuntu 16.04 (and I want to keep secure boot) After that, starting a VM results in a different error: "RTR3InitEx failed with rc=-1912. The Virtualbox kernel modules do not match this version of VirtualBox" Running /sbin/vboxconfig resulted in failure, and this is what I can see in the log: "SUP_IOCTL_COOKIE: Version mismatch. Requested: 0x290000 Min: 0x290000 Current: 0x240000". What is next? Thanks!

  • which version of the modules did you download? – ravery Jan 18 '18 at 0:19
  • Have you tried installing virtual box with apt? – Sebo Jan 18 '18 at 0:45
  • Sebo - several times, with different issues. That is strange since I was using VBox on Debian since 3 years ago – sheremey Jan 18 '18 at 0:57
  • ravery virtualbox-5.2_5.2.6-120293~Ubuntu~xenial_amd64.deb and Oracle_VM_VirtualBox_Extension_Pack-5.2.6-120293.vbox-extpack – sheremey Jan 18 '18 at 1:00
  • P.S. The hardware is HP Spectre x360 Convertible - 15-bl0XX – sheremey Jan 18 '18 at 1:02
0

Here is what I did.

Step 1: Setup Apt Repository

Firstly edit /etc/apt/sources.list file and add the following line: deb http://download.virtualbox.org/virtualbox/debian xenial contrib

Do this by opening the Software Updater and click on Settings. Click on "Other Software", then click "Add..." button. Copy line above into it. Close, then click "Reload".

Step 2: Setup Oracle public key

After adding required apt repository in your system, download and import the Oracle public key for apt-secure using following commands.

wget -q https://www.virtualbox.org/download/oracle_vbox_2016.asc -O- | sudo apt-key add -
wget -q https://www.virtualbox.org/download/oracle_vbox.asc -O- | sudo apt-key add -

Step 3: Install Oracle VirtualBox

After completing above steps, let’s install VirtualBox using following commands. If you have already installed any older version of VirtualBox, Below command will update it automatically.

sudo apt-get update
sudo apt-get install virtualbox-5.2

Step 4: Install dkms packages to ensure that the VirtualBox host modules are correctly updated if the kernel version changes during the next upgrade.

sudo apt-get install dkms

Step 5: Start VirtualBox

We can use dashboard shortcuts to start VirtualBox or simply run following command from a terminal.

virtualbox

On your first start, VirtualBox may prompt you to accept the license agreement. Updates will come automatically.

Recommendation:

Virtual Box offers a “Guest Additions”; a package of device drivers and system applications which typically improves performance, especially of graphics.

  • Thanks. I attempted to do exactly that yesterday several times. Just in case, I've repeated this today. The result: The following packages have unmet dependencies: virtualbox-5.2 : Depends: libqt5core5a (>= 5.7.0) but 5.6.1+dfsg-3ubuntu6~4 is to be installed Depends: libqt5widgets5 (>= 5.7.0) but 5.6.1+dfsg-3ubuntu6~4 is to be installed Depends: libvpx4 (>= 1.6.0) but it is not installable E: Unable to correct problems, you have held broken packages. – sheremey Jan 18 '18 at 2:34
  • P.S. For some reason, direct installations of libqt5 don't help, and if instead of taking the apt-get rout, I install the vbox from .deb files, there are no libqt issues whatsoever, the vbox manager loads just fine and there are sticky kernel issues after attempts to start an actual VM (the original post) – sheremey Jan 18 '18 at 2:37
  • I had a similar problem like that with something I tried to install. I ended up getting Muon Package Manager and got my dependencies with that. I was able to fix my broken packages. – Dave Jan 18 '18 at 23:32
  • Since I suspect that my prior installations introduced some mess, and there is no one out there popped up with a solution to resolve the kernel conflict (see OP), I have resorted to the Infamous Microsoft Windows Solution and did a clean reinstallation of Ubuntu from scratch! After that, to keep the experiment pure, I followed the exact steps in the Dave's proposed solution, and what do you think? - VBox loadsGUI loads just fine, however an attempt to start a VM looks very similar to the initial problem: Kernel driver not installed (rc=-1908). vbox 5.2.6 r120293 ubuntu 16.04 LTS – sheremey Feb 13 '18 at 8:14
  • P.S. This looks absolutely stupid, since I was using this VM guest under both Linux (debian) and Windows 7 hosts since 2013 just fine, it was exported safely as an appliance and imported to the new VBox (just in case). Still, LTS16.04 + VBOX 5.2 just doesn't seem to work... – sheremey Feb 13 '18 at 8:19

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.