I have my computer installed choosing the default sources server. Then today I encountered this error:

Err:10 http://cn.archive.ubuntu.com/ubuntu xenial Release                      
  Connection failed [IP: 80]
Reading package lists... Done
E: The repository 'http://cn.archive.ubuntu.com/ubuntu xenial Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

The sources list is here: Ubuntu wiki

I switched several servers in the site above. I also tried apt clean and several methods.

However, when I followed the PackageManagerTroubleshootingProcedure, it worked well when switched to main server.

I wonder why this occurred?

BTW, the server is much faster than the main server for my network, so I prefer to the former one.

  • The local server you were using was probably down at the time. Change it back later and try again. – user692175 Jan 17 '18 at 16:45
  • How did that happen? I think there should be many servers in the whole country. – Ssuching Yu Jan 18 '18 at 3:53

I change the sources.list to another server(NetEase 163 Mirrors), then the problem was fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.