5

I have installed Nvidia CUDA Toolkit version 9.1 which includes the drivers as well and I am able to get output from:

$ nvcc --version 
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2017 NVIDIA Corporation
Built on Fri_Nov__3_21:07:56_CDT_2017
Cuda compilation tools, release 9.1, V9.1.85

But when I use this command, I get the following error message:

$ nvidia-smi
nvidia-smi: command not found

And secure boot is also disabled. I have checked this after a restart and also after reinstalling the same by performing purge nvidia and doing a reinstall. Is there anything else which I can try?

6
  • Did you solved it?
    – khan
    Apr 9, 2018 at 16:22
  • Nope.Tried the web based installed which they have provided to get better results.Waiting for Ubuntu 18.10 as it is a LTS so it should have better support. Apr 12, 2018 at 10:43
  • I am having the same issue now (July 27, 2018). Have you had any luck yet?
    – tmakino
    Jul 25, 2018 at 5:36
  • @tmakino I probably think that this issue pertains to ubuntu 17.10 and i would advise you to try the same in Ubuntu 18.04 which is a LTS(Long Term Support) for which the Nvidia toolkit would probably install properly.Or you can try their web based installer which could give you better results. Jul 26, 2018 at 19:05
  • Thanks. I'm still on 16.04, but I'll update to 18.04 asap.
    – tmakino
    Jul 27, 2018 at 2:42

0

You must log in to answer this question.

Browse other questions tagged .