0

I had an "old" unused Toshiba Satellite M50D-A at my place (it didn't have any OS installed anymore), so I decided to put Ubuntu 16.04.3 LTS on a USB and give it a try. It might be worth noting that I'm entirely new at these things and I have little to zero IT knowledge as well.

Anyway, this is what I did (remember Windows was already erased before I started doing this):

1) Downloaded Ubuntu 16.04.3 LTS 64-bit

2) Used Rufus to create a bootable USB

3) Plugged it into my laptop and went for "Try Ubuntu" in GRUB

4) Installed Ubuntu through the live session

After a successful install, however, Ubuntu doesn't want to boot (unless I plug in the USB again which gives me the same options again as in the beginning - Try Ubuntu, Install Ubuntu, etc).

The following error pops up for about 2 seconds:

Failed to open \EFI\BOOT\mmx64.efi - Not Found

Failed to load image \EFI\BOOT\mmx64.effi: Not Found

Failed to start MokManager: Not Found

Failed to open \EFI\BOOT\grubx64.efi - Not Found

Failed to load image \EFI\BOOT\grubx64.efi: Not Found

start_image() returned Not Found

Followed immediately by:

Reboot and select proper Boot device

or Insert Boot Media in selected Boot device and press a key

After booting a live session through USB again, I followed some steps to install Boot Repair. The recommended repair didn't change anything, unfortunately. Here's my pastebin: https://paste.ubuntu.com/26401439/

I also disabled Secure Boot, and the Boot Mode is set to UEFI.

I hope someone is able to help!

Sincerely,

  • Have you tried just starting again from the start and reinstalling Ubuntu? It's probably not what you want to hear but it might fix up the issue and if it works it would probably be quicker than trying to fix the issue. – Puddler Jan 17 '18 at 2:10
  • 1
    Hey, thanks for answering! Unfortunately this is my 4th or 5th attempt at installing from scratch (downloading + rufus + install), and I'm always getting the same error (although the first two times the "Failed to start MokManager: Not Found" wasn't there)... – Michaël de Clercq Jan 17 '18 at 2:14
  • Not sure if P50 similar or not. Many issues are more by Vendor that specific model. Can't boot into Ubuntu on a Windows 8 machine (Toshiba P50) Manually copy files cp & mv ubuntuforums.org/showthread.php?t=2257259 & ubuntuforums.org/showthread.php?t=2261061 Toshiba L50-A-1EH laptop - used bcd edit ubuntuforums.org/showthread.php?t=2295628 and: ubuntuforums.org/showthread.php?t=2346022 – oldfred Jan 17 '18 at 2:24
  • you installed grub to the USB not the HDD. Use manual partitioning and deselect the efi partition on the USB and select/create the EFI partition on the HDD. – ravery Jan 17 '18 at 2:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.