2

My second screen flickers to black every now and then. It seems to be dependent on what is being drawn in it, because if I just have the desktop open, then it won't flicker very much, but if I have a program in it, it will flicker a lot, and if I have a youtube video playing in firefox on that screen, it will flicker so much that it's off about 85% of the time, and it becomes unusable until I can get firefox onto the main screen. I have used 3 graphics cards in my computer since it started: Radeon R7 260X, AMD RX 550, and AMD RX 560. The second screen is in portrait mode, not landscape. The screen works perfectly fine on Windows, so I know it has something to do with my drivers on Linux. I looked at https://ubuntuforums.org/showthread.php?t=2061180 and it looks most like my problem, except I'm on AMD instead of NVIDIA.

cat /etc/lsb-release outputs

DISTRIB_ID=Ubuntu 
DISTRIB_RELEASE=16.04 
DISTRIB_CODENAME=xenial 
DISTRIB_DESCRIPTION="Ubuntu 16.04.3 LTS"

uname -a outputs

Linux [my hostname lol] 4.13.0-26-generic #29~16.04.2-Ubuntu SMP Tue Jan 9 22:00:44 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

lspci -nnk | grep -iA2 vga outputs

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:67ff] (rev cf)
Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:8a91]
Kernel driver in use: amdgpu

env | grep DESK outputs

DESKTOP_SESSION=ubuntu
GNOME_DESKTOP_SESSION_ID=this-is-deprecated
XDG_SESSION_DESKTOP=ubuntu
XDG_CURRENT_DESKTOP=Unity

Thanks!

1

Oh hey i figured it out. Yay. I followed the instructions here: https://www.reddit.com/r/SolusProject/comments/53nvcm/help_screen_flickering_on_rx_480_with_amdgpu_on/?st=jcidz4k7&sh=3ec07c37

This is what it says: Open up a terminal and run

sudo gedit /etc/X11/xorg.conf.d/20-amdgpu.conf

A blank document will pop up. Inside, you need to paste in this stuff.

Section "Device"

Identifier  "Radeon RX 480"

Driver "amdgpu"

Option "AccelMethod" "glamor"

Option "DRI" "3"

Option "TearFree" "on"

EndSection

Why this isn't an automatic setting is beyond me. Ah, Ubuntu. I love you so much.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.