4

I have a Dell Inspiron 5568 laptop that is no longer booting up under Windows 10. The native (Dell) recovery options are not allowing me to backup any of my data prior to attempting a factory reset. Consequently, I have changed the BIOS settings for "legacy boot" and booted up from an Ubuntu Live 16.04 USB stick. Here is what I see

 parted -l reports

 Partition 1  524Mb  FAT32 EFI System partition             boot,esp
 Partition 2 134Mb         Microsoft reserved partition     msftres
 Parition 3  495Gb         Basic data partition             msftdata
 ...
 Parition 8  148Gb         Basic data partition             msftdata
 Parition 9  472Mb  ntfs                                    hidden,dflag
 Two more hidden ntfs paritions

fdisk -l reports

/dev/sda1    500Mb  EFI System
/dev/sda2    128Mb  Microsoft reserved
/dev/sda3    460G   Microsoft basic data
...
/dev/sda8    138Gb  Microsoft basic data
/dev/sda9    450M   Windows recovery envirionment
Two others

Before I attempt to do anything else I would like to mount /dev/sda6 and get a safe backup of some critical files I have there. The trouble is it is not clear to me how I mount that partition. I tried

mkdir /media/windows
sudo ntfs-3g -o force,rw /dev/sda6 /media/windows

only to be told that it is not an NTFS parition. If memory serves me right when I did the parititiong I had used the Windows 10 default which I think is FAT32. So I did try

mount -t vfat /dev/sda6 /media/windows

but that yields the error

mount: wrong fs type, bad option, bad superblock on /dev/sda6,
       missing codepage or helper program or other error

...very helpful :-) Can anyone here tell me what that might be?

6
  • 2
    Did you try plain mount without any options? mount /dev/sda6 /path/to/mountpoint? Sometimes it works. I had an issue like that once. Commented Jan 16, 2018 at 17:55
  • Just did and with exactly the same error message as for mount -t vfat...
    – DroidOS
    Commented Jan 16, 2018 at 18:00
  • You said it is no longer booting up. Did you check the target partitions you intended to mount? It may not be booting up because of corrupted partitions. Commented Jan 16, 2018 at 18:10
  • How do I check for corruptions?
    – DroidOS
    Commented Jan 16, 2018 at 19:00
  • fsck /dev/sda6 ? Commented Jan 17, 2018 at 4:12

2 Answers 2

5

I eventually discovered what was causing this issue. Unbeknownst to me the Dell Inspiron was using Bitlocker so the disk partitions in question were encrypted. Just how this can be is a mystery to me - to the best of my knowledge Windows 10 Home (which I have) does not support BitLocker. Perhaps it is a tweak added in especially for Dell.

2
  • 1
    so how did you resolve the issue?
    – sidgate
    Commented Apr 18, 2018 at 12:58
  • 2
    I got the computer working - albeit very very slowly with a lot of disk churning - in Windows safe mode and copied the entire Windows partition on to an SSD in an external housing. Once done I replaced the faulty disk with the SSD. With the original hard disk in such bad shape the process took several hours.
    – DroidOS
    Commented Apr 19, 2018 at 2:59
2

Sometimes it's an encrypted partition (in that case you're out of luck), sometimes ­– in particular, if it's a large partition ­– it's just an exfat.

1
  • 1
    Thanks, @DrMickeyLauer, this resolved my issue. I had a USB drive that was showing as type "Microsoft basic data" and setting the type to "exfat" in /etc/fstab worked for me.
    – synthetiq
    Commented Nov 17, 2022 at 18:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .