Hello brave Linux community.

I have a CanoScan LiDE 200, which used to work seamlessly up to now, whenever I needed it (a couple of times per year).

Unfortunately the last time, although it is properly recognized and more-or-less working, it has a strange artifact. In the middle of the scanning area, there is a black bar only for bright colors (i.e. white or near-white).

This is not a fault of the scanner, since I tried it also once more under OSX and works perfectly.

To understand what is goung on, I have attached a linux scan as well as an osx scan to see the difference.

It might be related to this ancient question here, but the problem is that the scanner used to work up to recently. Any ideas what is wrong?

Linux scan Linux Scan

OSX scan OSX Scan

  • I wondered if you were using Ubuntu 17.10;
    – pdc
    Commented Jan 17, 2018 at 0:11
  • I'm having the same problem (with a Canoscan LiDE 100). It worked great previously.
    – Nick Clark
    Commented Feb 5, 2018 at 21:49
  • 2
    Indeed I am using Ubuntu 17.10. The problem is with the xsane library which broke some things. More info here: bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/1731459
    – Panayotis
    Commented Feb 6, 2018 at 21:37

1 Answer 1


As suggested in the comments and the linked bug report, downgrading the sane backend to version 1.0.25 worked.

I followed these instructions: https://help.ubuntu.com/community/CompileSaneFromSource

Here are the commands I ran:

sudo apt-get install libusb-dev build-essential libsane-dev libavahi-client-dev libavahi-glib-dev
git clone git://anonscm.debian.org/collab-maint/sane-backends.git
cd sane-backends/
git checkout tags/upstream/1.0.25
./configure --prefix=/usr --libdir=/usr/lib/x86_64-linux-gnu --sysconfdir=/etc --localstatedir=/var  --
sudo make install
# reboot

Not the answer you're looking for? Browse other questions tagged .