4

I'm suddenly experiencing issues with my touchpad, which has become way too sensitive. Whenever I touch it to move the pointer, that touch also registers as a click. If I hover over input fields like the one I'm typing in right now. It didn't happen with the Ubuntu 17.10 update, it just randomly happened today. It also happened to me once before, then a reboot did the trick, but that doesn't work this time.

This problem is basically the same as 14.04 Touchpad is too sensitive, but because of Wayland or something, all the proposed solutions from there are no longer valid.

Output of xinput list:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ xwayland-pointer:13                       id=6    [slave  pointer  (2)]
⎜   ↳ xwayland-relative-pointer:13              id=7    [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ xwayland-keyboard:13                      id=8    [slave  keyboard (3)]
  • Have you tried "xset m 0 0"? – L.S. Jan 16 '18 at 13:42
  • Just did (thanks), but it doesn't seem to have any effect on this. – Jon Harald Søby Jan 16 '18 at 13:53
2

I resolved this by turning off tap-to-click in dconf-editor (/org/gnome/desktop/peripherals/touchpad/tap-to-click).

screenshot

However, although this was already set to false, it was still responding to taps on the touchpad. To resolve this, I followed the instructions from here.

Run:

apt list --installed | grep xserver-xorg-input

look for the following packages:

  • xserver-xorg-input-libinput (keep this)
  • xserver-xorg-input-synaptics (remove this package)

Reboot.

  • Removing xserver-xorg-input-synaptics* fixed this issue for me. I'm using Kubuntu 18.04 and have an Elantech touchpad. Before removing the synaptics driver, the touchpad was very jumpy and most options in the touchpad settings were grayed out. After removing the driver, all is good. – NickF May 15 '18 at 5:27
0

gsettings allows you to edit these settings. I had the same problem and stumbled across a few other posts.

First, find your touchpad name with:

gsettings list-schemas | grep touchpad

It might be something like org.gnome.desktop.peripherals.touchpad like mine. Then, you can see all the settings with:

gsettings list-keys org.gnome.desktop.peripherals.touchpad

But of course, replace with your touchpad name. Here is the list from mine:

send-events
natural-scroll
tap-to-click
two-finger-scrolling-enabled
left-handed
click-method
speed
scroll-method
tap-and-drag
edge-scrolling-enabled
disable-while-typing

To see the value of a setting, in this case speed:

gsettings get org.gnome.desktop.peripherals.touchpad speed

Pointer speed for the touchpad. Accepted values are in the [-1..1] range (from "unaccelerated" to "fast"). A value of 0 is the system default.

I changed mine to -0.1 which seemed to work for me. To set a value on a setting, change get to set and put the new value on the end:

gsettings set org.gnome.desktop.peripherals.touchpad speed -0.1

I don't know yet if these settings will persist as I just changed them. If anyone has improvements to this answer, please share!

Here are my references: https://ubuntuforums.org/showthread.php?t=2383952, https://askubuntu.com/a/980275/802976

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.