0

Very new to ubuntu. Have a Arduino compatible board PCDuino3 (no longer made) but the Arduino IDE compiler will not work with any 3rd party drivers for adafruit boards for some reason. I keep getting 'library errors'. Note with this Arduino board it has a HDMI i/f so i'm not using OTG cables and running the IDE from my PC but directly on the board's Ubuntu OS with kbd and mouse. Some libraries do seem o import for the IDE but the 2 I need for the 2 adafruit boards I have (RTC and servo / motor board)

So I have installed Geany

Now I need to know what folder do I install / clone github libraries using say git clone https://github.com/ https://github.com/adafruit/RTClib

so when I add the include line in my c app for the library #include < RTClib.h>

the compiler does comes up with an error saying 'No such file or directory'

I have tried cloning to a folder say /home/ubuntu/libraries which I created and used the following switch in the geany compiler properties -L/home/ubuntu/libraries/RTCLib but still get the same message.

Is there a default folder I should clone the libraries into, even if I have to sudo the clone. I have tried /usr/include and /usr/lib folders using sudo git clone https://github.com/ https://github.com/adafruit/RTClib

Thanks in advance for any help. I have been searching the web for the past 2 days solid looking for answers. regards Richard.

  • Looks like you should use -I /home/ubuntu/libraries/RTCLib. – muru Jan 16 '18 at 9:19
  • Sorry for the dumb question but is that in the command line of the geany compiler properties or something to do with the git clone? – Richard Vince Jan 16 '18 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.