I have an old Dell XPS 15 laptop running Ubuntu 16.04.3. I've always been experiencing annoying touchpad gesture behavior, for example when I try to scroll (2 fingers) and I touch the bottom of the touchpad, my unity menu always opens and then it activates whatever icon is under the cursor.

I'd like to disable it but I have no idea how to. I've searched through some other people's questions but could not find an answer for it.

Here is my (default) synclient configuration:

$ synclient 
Parameter settings:
    LeftEdge                = 64
    RightEdge               = 1536
    TopEdge                 = 48
    BottomEdge              = 852
    FingerLow               = 25
    FingerHigh              = 30
    MaxTapTime              = 180
    MaxTapMove              = 80
    MaxDoubleTapTime        = 100
    SingleTapTimeout        = 180
    ClickTime               = 100
    EmulateMidButtonTime    = 75
    EmulateTwoFingerMinZ    = 282
    EmulateTwoFingerMinW    = 112
    VertScrollDelta         = 36
    HorizScrollDelta        = 36
    VertEdgeScroll          = 0
    HorizEdgeScroll         = 0
    CornerCoasting          = 0
    VertTwoFingerScroll     = 1
    HorizTwoFingerScroll    = 1
    MinSpeed                = 1
    MaxSpeed                = 1.75
    AccelFactor             = 0.108992
    TouchpadOff             = 2
    LockedDrags             = 0
    LockedDragTimeout       = 5000
    RTCornerButton          = 2
    RBCornerButton          = 3
    LTCornerButton          = 0
    LBCornerButton          = 0
    TapButton1              = 1
    TapButton2              = 3
    TapButton3              = 0
    ClickFinger1            = 1
    ClickFinger2            = 1
    ClickFinger3            = 0
    CircularScrolling       = 0
    CircScrollDelta         = 0.1
    CircScrollTrigger       = 0
    CircularPad             = 0
    PalmDetect              = 0
    PalmMinWidth            = 160
    PalmMinZ                = 200
    CoastingSpeed           = 20
    CoastingFriction        = 50
    PressureMotionMinZ      = 30
    PressureMotionMaxZ      = 160
    PressureMotionMinFactor = 1
    PressureMotionMaxFactor = 1
    ResolutionDetect        = 1
    GrabEventDevice         = 0
    TapAndDragGesture       = 1
    AreaLeftEdge            = 0
    AreaRightEdge           = 0
    AreaTopEdge             = 0
    AreaBottomEdge          = 0
    HorizHysteresis         = 9
    VertHysteresis          = 9
    ClickPad                = 0

Not sure if it matters, but I only have this issue when I scroll up and start my fingers at the bottom edge of the touchpad.

  • can you tell us please what you tried already ? Looking through askubuntu and other sites the seems to be a lot of Dell XPS touchpad related issues like these – Robert Riedl Jan 23 at 9:24
  • Do you have similar problems on different desktop environments? – Nonny Moose Jan 24 at 1:15
  • I looked on askubuntu and saw a couple similar problems indicating it should be solved with synclient clickfinger options. I tried different values for all ClickFinger1 to 3 without any effect. The solution was for a ubuntu 14 but I don't see how that's going to make a big difference. – Jakke Jan 24 at 13:44
  • @RobertRiedl Thanks for that link. The 'apt install xserver-xorg-input-libinput' did the trick, but now I lost the tap-to-click function. – Jakke Jan 24 at 13:54
  • oh god this sounds like a nightmare ! Can I suggest doing a clean install of 17.10, the most current release ? – Robert Riedl Jan 24 at 13:56

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.