2

I need to use X11 instead of wayland for Zoom.

When I select "GNOME on Xorg" my laptop freezes right after I click login. I have tried selecting "Ubuntu on Xorg" and have the same result.

I can only login to the default "GNOME".

Once I login to GNOME I can lock, log in as another user, select "GNOME on Xorg", unlock and I can get back to the desktop without it freezing. BUT echo $XDG_SESSION_TYPE returns wayland and not X11.

I'm running Ubuntu 17.10 on a new dell XPS 15.
GNOME 3.26.2
i7-7700HQ
Intel HD Graphics 630 / Nvidia GTX 1050
16 GB RAM
64 bit

  • I have this exact same issue on: HP Spectre x360 13, late 2016 model. i7-7500U, Intel HD Graphics 620 / Nvidia GTX 1050, 8GB; Any Chance you have found a solution? – pjcarly Feb 3 '18 at 10:19
  • I was unable to use x11 at all on 17.10. I did a fresh install and still had the same issue where choosing xorg would still use wayland. I did a fresh install of 16.04 and when I switched prime to use integrated graphics I got stuck with a login loop. Adding acpi_osi=! acpi_osi=Windows 2009 to grub fixed that. Then I was able to log in with integrated graphics enabled and x11 session. Zoom was still laggy during screen share so I installed cinnamon desktop. – Blake Zeiger Feb 4 '18 at 12:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.