17

I am experienced the following issue: after hibernation (using command sudo systemctl hibernatein a terminal or the menu on the right top of Ubuntu desktop) I get a black screen (Even though all devices seem to work. The fan works!) and I am forced to reboot the OS because resume failed and I can't back to a "saved state". The content in etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla is:

    [Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate;org.freedesktop.login1.handle-hibernate-key;org.freedesktop.login1;org.freedesktop.login1.hibernate-multiple-sessions;org.freedesktop.login1.hibernate-ignore-inhibit
ResultActive=yes

Additional info: Ubuntu version: 16.04LTS

Kernel version:

uname -r
4.13.0-26-generic

Graphic info:

udo lspci | grep -E 'VGA|Display'
[sudo] password di michele: 
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6730M/6770M/7690M XT] (rev ff)
michele@michele-ubuntu:~$ sudo lshw -c display | grep driver
       configuration: driver=i915 latency=0

CPU info:

sudo lscpu
[sudo] password di michele:
Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
CPU(s): 8
On-line CPU(s) list: 0-7
Thread(s) per core: 2
Core(s) per socket: 4
Socket(s): 1
NUMA node(s): 1
Vendor ID: GenuineIntel
CPU family: 6
Model: 42
Model name: Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz
Stepping: 7
CPU MHz: 1995.561
CPU max MHz: 2900,0000
CPU min MHz: 800,0000
BogoMIPS: 3991.12
Virtualization: VT-x
L1d cache: 32K
L1i cache: 32K
L2 cache: 256K
L3 cache: 6144K
NUMA node0 CPU(s): 0-7
Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm epb pti tpr_shadow vnmi flexpriority ept vpid xsaveopt dtherm ida arat pln pts

Why does the resuming fail? Thanks in advance for your help.

5

This seems to be a bug with the kernel 4.13.0-26-generic. See the bug report here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1743094?comments=all

The solution is to downgrade the kernel to 4.10.0-42-generic, but keep in mind that you'll lose the patch for Meltdown and some Spectre mitigations. The mainline kernels also fix the problem.

7
  • Thanks. In this case, is better for me if I disable hibernation. Can you suggest me how to do this, please?
    – michele_ub
    Jan 16 '18 at 15:42
  • 6
    Hibernation is absolutely critical functionality vs. simple "suspend to RAM" from a security standpoint. Everyone who's affected, please make sure you click on the link which says "This bug affects xx persons. Does this bug affect you?" at the top of the bug report, otherwise this bug might sit there unattended for months, if not years...
    – sxc731
    Jan 20 '18 at 15:09
  • Ok. I didi it! @sxc731
    – michele_ub
    Jan 22 '18 at 9:09
  • @michele_ub: Could you please open a new question if you have a new or follow-up question? The comment section is not suitable or meant for new questions or extended discussion. You’re welcome to send me a comment with a notification to draw my attention to it. Thanks. Feb 9 '18 at 18:01
  • Same problem with 4.13.0-36-generic. This answer fixed my problem.
    – jtlindsey
    Feb 27 '18 at 23:38
4

I'm using ubuntu 17.10 and after upgrade it from 17.04 i had this problem (black screen after suspend / hibernate).

I try change linux kernel with ukuu but no success.

After spend long time with this problem, i solve it installing laptop-mode-tools.

sudo apt-get install laptop-mode-tools

After install use lmt-config-gui to configure it. Working perfect now.

My kernel version is 4.15.13-041513-generic

2
  • 10
    And what was the configuration? Could u please explain more? Jun 5 '18 at 15:33
  • 1
    Not sure if it helps anybody else but for me, enabling the Enable module video-out option seemed to do the trick!
    – KVISH
    May 4 '20 at 5:14
2

I just installed xUbuntu 16.04LTS on a new LG Gram Laptop and ran into the same issue. I'm running Kernel 4.13.0-36-generic. To confirm that it wasn't something else, I did the following to make sure hibernation was setup:

  • disable secure boot
  • create /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla
  • Put the following in the file and save:

    [Re-enable hibernate by default in upower] Identity=unix-user:* Action=org.freedesktop.upower.hibernate ResultActive=yes

    [Re-enable hibernate by default in logind] Identity=unix-user:* Action=org.freedesktop.login1.hibernate;org.freedesktop.login1.handle-hibernate-key;org.freedesktop.login1;org.freedesktop.login1.hibernate-multiple-sessions;org.freedesktop.login1.hibernate-ignore-inhibit ResultActive=yes

  • confirmed cat /sys/power/disk output shutdown reboot suspend test_resume

Now the system hibernates but I got a black screen as if its frozen on resume. I couldn't get to terminal with CTRL+ALT+F1 or back to display with CTRL+ALT+F7 commands or ssh into the machine from another computer.

Selecting a older kernel (4.10.0-28-generic) on boot like suggested here worked for me, but i was concerned about the security. So i tried using the ukuu tool to enable easy installation of mainline kernels and be able to easily roll back. I tried 4.14-21 (part of LTS) and it works without problems so far.

Similar issues here.

1
1

Maybe changing the locker might be worth a shot on xubuntu you could use xfce4-screensaver instead of light-locker.

Howto change:

sudo apt-get remove light-locker
sudo apt-get install xfce4-screensaver

And then restart.

Instead of xfce4-screensaver, you could also try another locker.

1
  • works for me! Thanks! Remember to restart :) Now I open my laptop and press enter, the login appears
    – ianaz
    Oct 4 '19 at 7:25
0

I just re-installed and have slowly re-built my Ubuntu-18.04. And after each new thing I re-install I am retesting my Hibernation.

So far with a fresh install and even with the above ppa ...

sudo add-apt-repository ppa:graphics-drivers ...

and I have installed again Nvidia-396 (most current {not tested}) driver and hibernation is not a problem yet - so I stand corrected.

I have found 2 places where to find logs that show a working set of tasks, and errors ... and pathetically did not know they existed. Great for trouble shooting. For your Info they are:

/var/log/syslog ... and /var/log/pm-suspend.log

They may help other with this quirky problem,

trying to Help, Mark

Not the answer you're looking for? Browse other questions tagged or ask your own question.