1

I was facing some issues with wifi disconnection. So I followed some askubuntu forum answers and solved the problem by manually installing the wifi device. But still I had to follow the first answer of this question (How do I get an RT3290 wireless card to work?) to make it work on every start up.

Then suddenly it stopped working now. Now when I run sudo lshw -C network it gives me this error.

*-network UNCLAIMED     
       description: Network controller
       product: RT3290 Wireless 802.11n 1T/1R PCIe
       vendor: Ralink corp.
       physical id: 0
       bus info: pci@0000:08:00.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:b5510000-b551ffff
  *-network
       description: Ethernet interface
       product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: eno1
       version: 08
       serial: a0:1d:48:d1:23:d9
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8106e-2_0.0.1 04/23/13 ip=192.168.1.3 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:42 ioport:4000(size=256) memory:b5404000-b5404fff memory:b5400000-b5403fff

it says network UNCLAIMED. Why is that ? How can I solve that issue ?

When I run lspci it shows me my wifi adapter model as

08:00.0 Network controller: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe

I followed this. But it says that it will work when secure boot is disabled. But the thing is I've already disabled secure boot and I was working fine about two hours ago.

How can I solve this? Any help would be much appreciated.

  • try using a USB WiFi adapter and then if that works replace the wireless card in your pc or laptop. I have a HP that had a bad Intel card and that was not compatible and I replaced the card and now it works. – Guy Byrd Jan 15 '18 at 16:05
  • But it was working few hours ago. The only thing I did is turning off my laptop and turning back on after few hours – Thidasa Pankaja Jan 15 '18 at 16:06
  • So the problem persists after reboot? UNCLAIMED is not the same as in the link you posted DISABLED. I think UNCLAIMED in this context means you have a driver, but it has not claimed the device. Probably you can manually bind the device to the module / driver. lspci -knn should give you the driver name. Than use that in tree /sys/ | grep module_name. This should give u the path to the driver. Than as root echo "0000:08:00.0" > /sys/path/to/driver/bind. – AlexOnLinux Jan 15 '18 at 17:52
  • @AlexOnLinux When I run the command tree /sys/ | grep module_name with my module name this returns nothing. – Thidasa Pankaja Jan 16 '18 at 0:35
  • @Pankaja Paranavitharana could you please Edit your question and add the output of lspci -knn – AlexOnLinux Jan 16 '18 at 6:32
-1

I had exactly the same problem today. Turned off my laptop after finishing with my job and than turning it back on when I got home. Ubuntu wasn't able to find any wi-fi. I know that this might sound stupid, but try turning off (not restarting) your pc, leave it for a few seconds or a minute and then turn it back on. This, no matter how stupid it sounds, just solved my problem and I'm able to use wifi again (I also ran sudo apt-get update and sudo apt-get upgrade, which I don't think helped solving this issue, but updating can't be bad). Just for the record, I was also restarting my laptop few times but it didn't helped.

Hope this helps you.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.