1

I'm fairly new to Ubuntu and using version 17.10 with Gnome 3.26.2 in a VirtualBox VM. Occasionally (once a day?) an unauthorised and automatic connection to "extensions.gnome.org" on port 443 is executed (I catch it with a network monitor on the macOS host).

How can I disable this highly unwanted and privacy-invading behaviour? I've spend hours searching for the magic switch for this one without luck.

It is not related to any settings I can control with the Software & Updates application. There are also no options to disable it with something in the Settings application. Additionally I already installed the dconf Editor application and made sure that the value of org/gnome/software/download-updates is set to false (which seems to be the default.) Additionally org/gnome/shell/disable-extension-version-validation is at the default value of "true".


Update: when I block the request (e.g. via macOS) then following is dumped to the Ubuntu syslog: "gnome-software[1693]: failed to call gs_plugin_refresh on shell-extensions: [*/*/*/source/shell-extensions/*] failed to download https://extensions.gnome.org//static/extensions.json: Cannot connect to destination"


Update #2: chrome-gnome-shell and potential browser add-ons for the GNOME Shell integration are not installed on my system.

3
  • Just add extensions.gnome.org to the hosts file (in Ubuntu), and point it to 0.0.0.0 - ?
    – JonasCz
    Jan 15 '18 at 15:44
  • @JonasCz I don't want to block it entirely. I might want to visit that website one day. I just don't want it do regularly connect by itself for no reason there in an automatic fashion.
    – Haru
    Jan 15 '18 at 15:48
  • @Haru when that day comes, just undo that modification to hosts
    – muru
    Jan 15 '18 at 16:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.