4

I'm running Ubuntu 16.04 guest on a Windows 10 host with VirtualBox 5.2.4. I have an Nvidia GTX 1050 graphic card.

I've followed all the necessary steps to enable 3D acceleration as in here, and everything seems to have worked correctly, if it wasn't for a constant pixel flickering affecting transparencies. The flickering also affects the upper bar randomly. Here is a screenshot:

Ubuntu graphic glitch

The system seems to run a bit faster, and it's SORT of usable, but the glitch is very annoying. The solution given for this other problem didn't help.

What else can I try?

2
  • having the same problem, 5.2.8 is supposed to fix this but didn't work for me
    – luffy
    Mar 3, 2018 at 10:12
  • After months I found out that the solution for me was to make Virtual Box use the NVidia graphic card instead of the integrated intel one!!
    – m3rosss
    Oct 3, 2018 at 7:20

1 Answer 1

6

I had the same issue as you after enabling 3D acceleration but the solution (at least for me) is in this article, at the very end.

sudo apt-get install compizconfig-settings-manager && ccsm

Go to OpenGL and untick Framebuffer Object. Also, you might want to disable effects, such as fading windows, animations and window decoration.

Hope that this will do the trick for you too.

3
  • I had the same issue and this fixed it, thank you Mar 23, 2018 at 15:15
  • This 'almost' worked, it removed many glitches, but there still some artifacts from time to time, thanks anyway!
    – m3rosss
    Mar 26, 2018 at 13:01
  • 1
    This solved the problem for some version. But unfortunately the problem reappeared after upgrade to virtualbox 5.2.12 :(
    – matli
    Jun 26, 2018 at 7:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.