While trying to update on my Ubuntu 16.04 system I get the following errors:

E: Failed to fetch http://de.archive.ubuntu.com/ubuntu/dists/xenial/main/binary-arm64/Packages  404  Not Found [IP: 80]
E: Failed to fetch http://de.archive.ubuntu.com/ubuntu/dists/xenial-updates/main/binary-arm64/Packages  404  Not Found [IP: 80]
E: Failed to fetch http://security.ubuntu.com/ubuntu/dists/xenial-security/main/binary-arm64/Packages  404  Not Found [IP: 2001:67c:1360:8001::17 80]
E: Failed to fetch http://de.archive.ubuntu.com/ubuntu/dists/xenial-backports/main/binary-arm64/Packages  404  Not Found [IP: 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.

I tried the solutions suggested here: 16.04 Upgrade: Failed to fetch Empty files can't be valid archives

but none of them worked for me. I've had this problem for a while now. My architecture is


Foreign archs are


I cannot simply remove the ARM architecture because it is needed for the NVidia SDK I'm developing with.

Any help would be appreciated!

  • This happens because the server is unavailable. You might want to change your mirror from your regional to main, while waiting your regional mirror online again. Read more: askubuntu.com/questions/104695/… – Aryo Adhi Jan 15 '18 at 10:27
  • 1
    @AryoAdhi Servers that aren't available are hardly available to give a 404 HTTP response. – Chai T. Rex Jan 15 '18 at 10:28
  • 1
    Please add to your question the output of dpkg --print-architecture and dpkg --print-foreign-architectures. – Chai T. Rex Jan 15 '18 at 10:30
  • 2
    Possible duplicate of how to get rid of arm64 in apt – Chai T. Rex Jan 15 '18 at 10:37
  • 1
    No, you haven't read carefully: " I cannot simply remove the ARM architecture because it is needed for the NVidia SDK I'm developing with." I managed to solve the problem though, see below. – emilaz Jan 15 '18 at 11:00

Ok so I figured out both what's the problem (thanks to you guys) and how to solve it:

The problem was that the NVidia Driveworks SKD seems to mess with apt, as in that apt tries to look for updates on the ARM architecture as well and there is no such path in the predefined package path (thanks, @guiverc). Since I can't remove the architecture because I need it for development, I changed the /etc/apt/sources.list file by adding [arch=amd64,i386] where necessary. Example:

deb [arch=amd64,i386] http://archive.ubuntu.com/ubuntu xenial universe main restricted multiverse

Apt is then only looking for updates on those two architectures. This solved the problem.


You say your architecture is amd64, so I suggest you to find in the file /etc/apt/sources.list and all the files inside /etc/apt/sources.list.d that are not downloading properly and add [arch=amd64].

For example, change

deb http://de.archive.ubuntu.com/ubuntu/ xenial main

URL into

deb [arch=amd64] http://de.archive.ubuntu.com/ubuntu/ xenial main

Before editing, make a backup of these files. Once edited, try to update again your system.

Be careful. I never had to do this but if you save backups, it can't hurt.

  • The lines in /etc/apt/sources.list only go as long as http://de.archive.ubuntu.com/ubuntu/, and don't include the CPU architecture. – Chai T. Rex Jan 15 '18 at 10:57
  • @ChaiT.Rex: Sorry, I will edit my answer. Try that (after necessary backups). – Pierre François Jan 15 '18 at 15:05

Untick the unnecessary PPA's in the other software menu and the again try sudo update. 404 errors are mostly due to broken or dead links. This might solve your problem. If your problem still remains unsolved, follow https://askubuntu.com/a/92897/779822

  • What do you mean by "other software menu"? – emilaz Jan 15 '18 at 10:36
  • The errors aren't from PPAs, since the webserver de.archive.ubuntu.com will hardly know what PPAs are installed on your system in order to know that you should be punished with a 404. PPAs come from the server ppa.launchpad.net, which is a different server. – Chai T. Rex Jan 15 '18 at 10:39
  • @emilaz in the settings menu, open software &updates, there you must be having a other software tab. – Rishav Shukla Jan 15 '18 at 10:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.