I use Ubuntu 17.10 and just recently I experience mouse issue which can't click on wayland. If I switch to Xorg or unity my mouse click back to normal. The problem is I depending on wayland because my wine application works better on wayland, while on Xorg or Unity it crashes everytime I strated the program.

I already tried

sudo ubuntu-drivers autoinstall

but it doesn't seem bring any differences, Please help

  • What is the result of typing uname -r in the terminal? – WinEunuuchs2Unix Jan 15 '18 at 4:35
  • @WinEunuuchs2Unix it's 4.13.0-25-generic – 6warrior Jan 15 '18 at 7:00
  • this makes me frustated, i did a fresh install, it work for a moment but after i update and restart, the problem persist, meanwhile i'm on deadline. perhaps the problem is on the kernel, can anyone help? – 6warrior Jan 17 '18 at 9:58
  • 1
    Try using sudo rmmod psmouse followed by sudo modprobe psmouse as described in this answer and let me know. – WinEunuuchs2Unix Jan 17 '18 at 11:13
  • @WinEunuuchs2Unix it doesn't work – 6warrior Jan 17 '18 at 12:29

Disabling Wayland must solve this issue. Similar question was answered here. Worked for me.

If you wish to do it permanently, edit

/etc/gdm3/custom.conf and uncomment the line:


Save the file and then on reboot you will never see the cog asking for which session to use.

  • disabling wayland cause another problem, my wine application (skecthup) crashes everytime it started on xorg – 6warrior Feb 8 '18 at 23:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.