1

I followed a step-by-step tutorial to set up Electrum (Tor) for Ubuntu 16.04. After

sudo pip install pyasn1 pyasn1-modules pbkdf2 tlslite qrcode

I ignored the first orange notification,

that the directory is not owned by current user… etc

but tried to upgrade pip version from 8.1.1 to 9.0.1 with the command:

pip install –upgrade pip

After upgrading, it showed still the 8.1.1 version. After a second try (same command), it said it s already up to date.

So I finished the tutorial and tried to run

cd /home/username/electrum-xvg-tor
./electrum-xvg

but instead of executing, it said:

bash: ./electrum-xvg: Keine Berechtigung (no authorization)

Any suggestions, what I missed? How can I get the wallet running?

$ pip --version
pip 8.1.1 from /usr/lib/python2.7/dist-packages (python 2.7)

$ apt-cache policy python-pip
python-pip:
  Installiert:           8.1.1-2ubuntu0.4
  Installationskandidat: 8.1.1-2ubuntu0.4
  Versionstabelle:
 *** 8.1.1-2ubuntu0.4 500
        500 http://de.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
        500 http://de.archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages
        100 /var/lib/dpkg/status
     8.1.1-2 500
        500 http://de.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        500 http://de.archive.ubuntu.com/ubuntu xenial/universe i386 Packages

$ ls -l /home/username/electrum-xvg-tor/electrum-xvg

-rw-rw-r-- 1 username username 14345 Jan 14 16:19 /home/username/electrum-xvg-tor/electrum-xvg

5
  • Could you please post text files, dialogue messages, and program output listings as text, not as images? To achieve the latter two you can either 1) select, copy & paste the dialogue text or terminal content or 2) save the program output to a file and use that. Longer listings (the editor will tell you what's too long) should be uploaded to a pastie service and linked to in the question. Thanks. – David Foerster Jan 14 '18 at 21:19
  • Right, the main question was what I have to do to start the wallet. – PortWein Jan 14 '18 at 21:40
  • The list actually shortened since yesterday (?), hope this is the right edit form, so you can find the error. – PortWein Jan 15 '18 at 12:14
  • Did you run the last two commands from the linked instructions, pyrcc4 icons.qrc -o gui/qt/icons_rc.py && sudo python setup.py install? Did they succeed? What's the output of ls -l /home/username/electrum-xvg-tor/electrum-xvg? – David Foerster Jan 15 '18 at 12:59
  • Yes I ran all commands, and yes it succeed (there was no message or notification, it just took 1-2 secs and I had my next command line. – PortWein Jan 15 '18 at 14:14
0

Looks like there's a bug in the source code repository: the executable file appearing in the README document isn't flagged as executable (see my bug report).

You can change its access mode to make it executable yourself:

chmod +x electrum-xvg

Then you can execute it as documented:

./electrum-xvg
3
  • Thank you for your time, it starts now. :) Next step will be to connect the wallet. It gave out a "Not connected" warning during start. – PortWein Jan 15 '18 at 16:06
  • Could you please open a new question if you have a new or follow-up question? The comment section is not suitable or meant for new questions or extended discussion. You’re welcome to send me a comment with a notification to draw my attention to it. Thanks. – David Foerster Jan 15 '18 at 16:15
  • Just opened a new question yesterday, if you re in please have a look :) – PortWein Jan 16 '18 at 15:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.