0

After the latest apt update I have kernel 4.13 on my Ubuntu 16.04 LTS machine. Now I have two problems:

  1. The display freezes sometimes after some minutes (using NVIDIA driver 384.111).

  2. I cannot use VMWare Player 12 because the creation of the vmnet module fails (VMWare Player 14 works, but I don't have a license for that version).

Therefore I want to switch back to 4.10 and prevent Ubuntu from updating the kernel to 4.13 (updates of the 4.10 kernel should be allowed). How can I achieve this? I found that there is the apt-mark hold command, but how do I define that only the 4.13 is not used any more whereas the update of 4.10 still works?

5
  • Did you use apt or the software-center to install nvidia-384.111 or did you manually install something downloaded from the nvidia website?
    – mchid
    Jan 14, 2018 at 17:48
  • If you manually installed the nvidia driver (instead of using apt or the software-center), you will need to manually install it every time there is a kernel update. However, this is not necessary when you install the nvidia driver using apt or the software-center as the apt version will automatically update when you update the kernel.
    – mchid
    Jan 14, 2018 at 17:59
  • When did the kernel update happen? Jan 14, 2018 at 22:10
  • All updates happend "automatically", for the driver as well as for the kernel. I did not select any package manually. The update happened last week, I don't know exactly on which day.
    – drhuh
    Jan 15, 2018 at 9:26
  • Another option is to install 4.14.13 and ignore the 14.13.xx updates until they finish coming out in 6 months or so, then go back and delete them. This answer discusses many of your issues I think. You will have to take more control over monitoring kernel updates though. Jan 16, 2018 at 0:58

3 Answers 3

0

apt-mark hold is not necessary because, kernel 4.10 and 4.13 are two different kernels.

4.10 (the old kernel) should still be installed and you can select the old kernel from the grub menu when you boot your computer.

If grub does not display upon boot, you can hold down the SHIFT key when you boot to force the grub menu to display.


On the grub menu, select: "advanced options".

Then, select your desired kernel version (4.10).

Also, click here to see a helpful related answer about updating.

7
  • Sorry, this was not the question. I know how to boot 4.10 if 4.13 is the default kernel, what I want is to prevent Ubuntu from updating to 4.13 at all. I don't want to have this kernel on my machine, but still want to get updates of 4.10.
    – drhuh
    Jan 15, 2018 at 9:28
  • Why don't you just uninstall kernel 4.13? This should prevent 4.13 from being installed. This will uninstall the meta package kernel which should currently be installed. The meta package is what causes the updates, usually when you run a dist-upgrade. Because 16.04 is LTS, you should have some extra kernel packages available and so you can run the following command to see if any are available besides the one you have currently installed: apt-cache search 4.10 | grep -i linux
    – mchid
    Jan 16, 2018 at 15:42
  • With that said, you should consider installing an even newer kernel to see if the newer kernel (like 4.15) fixes your problem and this way, you will still get all the security updates and fixes as well.
    – mchid
    Jan 16, 2018 at 15:43
  • Well, I already had the idea of removing 4.13, but the command sudo apt remove linux-*-4.13* results in The following packages will be REMOVED linux-generic-hwe-16.04 linux-headers-4.13.0-26 linux-headers-4.13.0-26-generic linux-headers-generic-hwe-16.04 linux-image-4.13.0-26-generic linux-image-extra-4.13.0-26-generic linux-image-generic-hwe-16.04 and there I have the question whether I really want to remove the *-hwe_16.04 too. That's why I asked how to remove 4.13 without removing the option to receive the updates of the other kernels.
    – drhuh
    Jan 18, 2018 at 18:31
  • As far as I can tell, you will not get updates for 4.10. If you are having issues with 4.13, you should report your bugs and do not uninstall 4.13 and also do not uninstall hwe so that you can receive updates to the kernel which may provide a fix for your bugs.
    – mchid
    Jan 24, 2018 at 3:36
0

I have the same problems with kernel 4.13 in Desktop with AMD and laptop with Pentium Core-2-Duo. I both in 4.10 and used this (complete x with your version):

sudo apt remove --purge linux-image-4.13.x-xx-generic

sudo update-grub2

sudo reboot

No problems and the system continues the update for the current kernel (so far).

0

The best solution for GRUB was to set fixed in selected Kernel is (find the file in /etc/default/grub):

GRUB_DEFAULT=saved

GRUB_SAVEDEFAULT=true

With this settings the last selected value is kept for the next boot (forever, until you select another). If you have a new kernel you don't have to edit your config.

Don't forget to re-run sudo update-grub

The solution is from reading: info grub-mkconfig

You can select any kernel installed for test, if it fail you rebbot and select the old one. I use this every time the kernel updates, after the workday and test everything before accept the new one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.