Without performing any update, suddenly today when I tried to power on a VM in VirtualBox, the host machine (running Ubuntu 16.04) freezed.

  • I tried couple of times and the problem keep repeating.

  • I run memtest: all good

  • Tried to create a new VM just in case: same issue.

  • Downgraded the VirtualBox installation: didn't help at all.
  • Disabled network, shared folders etc: Nothing.

On the same machine I've also got Windows 10 in dual boot. I've got couple of VMs there in VBox and VMWare. Just to minimize the probability of any HW issue, I started the VMs there and they work just fine.

Any idea?

The only way to recover the host was to hard-reset.

ps: The freeze happens as soon as I click the "Start" button.

Host details:

  • VirtualBox: Version 5.0.40_Ubuntu

  • Kernel: 4.13.0-26-generic

  • Guest: irrelevant (windows 10, OpenSuse, CentOS)

  • The log file of VirtualBox is empty.

  • Thank you and thank to google because I got the same problem today. And google direct me to your post here. Really appreciate your work here. – Clock ZHONG Feb 4 '18 at 8:20
  • 2
    Same issue solved here: superuser.com/questions/1284705/… – chus Feb 9 '18 at 12:36

Figured it out after following:


(Had to upgrade VBox to 5.2 and all worked ok)

In case you need it, had also to follow : VirtualBox - RTR3InitEx failed with rc=-1912 (rc=-1912) in order to completely uninstall all the previous installations

There was a silent security update that caused old VirtualBox installations (older than 5.2) to hang the entire host.

| improve this answer | |
  • 3
    After installing 5.2 from Oracle, I had to uninstall virtualbox-dkms and reboot. – Juan Calero Jan 23 '18 at 8:48
  • simply completely uninstalling virtualbox with something like sudo apt-get remove virtualbox*or sudo aptitude remove virtualbox before installing the new version will do the trick. – DJCrashdummy Mar 1 '18 at 9:26

I really appreciate Sanosay, and Bertrand Lo question and answers here. I followed them and fixed this issue on my situation, let me summarize what I've done for this issue step by step completely here for your convenience:

  1. sudo apt autoremove virtualbox

  2. Reboot.

  3. Add deb https://download.virtualbox.org/virtualbox/debian xenial contrib into Ubuntu 16.04's software source list.

    (by start "Software & Updates, and choose the "Other Software" tab, and click "Add" button, then paste the deb https://download.virtualbox.org/virtualbox/debian xenial contrib in the APT line)

  4. sudo apt update && sudo apt install virtualbox-5.2

    Be cautious! It's virtualbox-5.2 instead of virtualbox.

  5. after installation, reboot

  6. run virtualbox, and you'll find that your virtualbox version is 5.2 now, and it'll not cause whole host ubuntu16.04 crash when run one guest OS.

The original version virtualbox in ubuntu16.04 could not work correctly with Ubuntu16.04 latest patch, even Canonical claims 16.04 is their LTS (Long Term Support) version, at least it couldn't support the virtualbox 5.0 now.

| improve this answer | |
  • Wow after so much remove re-install... crash then again, and again. Could not find out why the default virtualbox keep on crashing. Then I found this post. Thanks!!! – Llewellyn Feb 28 '18 at 18:45
  • 1
    Llewellyn, it's my pleasure to know you fixed this issue also. It's really a bug in Ubuntu16.04 LTS, but they didn't find and fix it, anyway, it's a free OS service, we couldn't blame Canonical team, but we still need the workable virtualbox. This shows the value of Google&StackOverflow websites, they are much more powerful than Canonical dedicated engineering&validation teams. – Clock ZHONG Mar 1 '18 at 8:35

also ran into this problem, thanks for the advices above! However, there's one more step that's missing for 'apt update' to work, new keys, paste this into Terminal:

wget -q https://www.virtualbox.org/download/oracle_vbox_2016.asc -O- | sudo apt-key add -
wget -q https://www.virtualbox.org/download/oracle_vbox.asc -O- | sudo apt-key add -

(from https://www.virtualbox.org/wiki/Linux_Downloads)

| improve this answer | |
  • Which advices are you referring to? The question states "Any idea?", for sure not something like an advice, right? If this is an addition to an existing answer, to further improve it, then please EDIT your answer to indicate which answer you mean. Also: "above" is relative ... it depends how someone browsing the existing answers has sorted those answers ... – Pierre.Vriens Feb 16 '18 at 10:05

Exactly this situation. And totally uninstalled.

And add repository of official VB:

deb https://download.virtualbox.org/virtualbox/debian xenial contrib

then reinstall. work as usual.

| improve this answer | |
  • 1
    I recommend to edit this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) – David Foerster Mar 22 '18 at 11:33
  • pity, i could not repeat the problem. It look like that came from the virtualbox silent update. as describe by Sanosay. – Bertrand Lo Mar 28 '18 at 2:54

Today I found Ubuntu16.04 already include virtualbox-5.2 into its latest patch: https://download.virtualbox.org/virtualbox/debian xenial/contrib amd64 virtualbox-5.2 amd64 5.2.10-122088~Ubuntu~xenial

So it means we could just use:

sudo apt upgrade

to fix this issue directly. Maybe Canonical dedicated engineering&validation teams also found this issue and read our post here. Now the solution is much simpler. Just one line command:

sudo apt upgrade

Then reboot.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.