0

I tried many things but to no avail (I added 'lv3:ralt_switch', 'misc:typo' to ’input-sources’ using dconf-editor). So how do I set up the 3rg and 4th level of the keyboard? I use En, Ru and Uk layouts + iBus for Sanskrit and Bengali. When I had MATE I also had troubles with setting it until I checked Miscellaneous Compatibility Options → Enable extra typographic characters. But in Xubuntu there is no such menu :(

  • It would probably help if you edited your question and gave us an example for one specific keyboard layout and told us exactly which character(s) are difficult to type. – Gunnar Hjalmarsson Jan 18 '18 at 14:22
  • I don't know how to edit my question so that it is more clear. I says it all. On my previous MATE machine I had a need to type "[" and "]" on Russian layout without switching to English just to type two characters and then switching back to Ru to continue typing. Another one is "...". Another one is "|". So in MATE I just edited "input-sources" in dconf-editor and checked "Enable extra typographic characters" and that was it. In Xubuntu I can't get that to work. So I don't think that English (US) don't include 3rd level symbols. In MATE it worked like a charm without any additional workaround. – brijabasi Jan 28 '18 at 5:29
  • Please see my edited answer. – Gunnar Hjalmarsson Jan 28 '18 at 13:04
2

Some keyboard layouts include 3rd and 4th level symbols, some don't. Those which do, such as the Ukrainian layout, enable the lv3:ralt_switch option automatically, so normally that's not necessary to set manually via dconf (or gsettings).

The English (US) and the basic Russian layouts don't include 3rd and 4th level symbols.

AFAIK, the xkb-option lv3:ralt_switch does not apply when using IBus input methods.

Edit:

One way to enable extra typographic characters system wide is to open the /etc/default/keyboard file for editing and make sure it includes the line:

XKBOPTIONS=misc:typo

Hopefully that makes a difference at next reboot.

| improve this answer | |
  • Thank you for your reply. However, I have exactly the same layouts and iBus on a MATE machine and it works perfectly well with ralt_switch. So I believe it should be possible in XFCE too? It didn't work until I checked the box specified above. – brijabasi Jan 18 '18 at 13:22
  • @brijabasi: I didn't mean to say that IBus wouldn't work if lv3:ralt_switch is enabled, but probably the IBus input methods don't make use of it. – Gunnar Hjalmarsson Jan 18 '18 at 14:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.