11

Maybe someone has posted this problem, but this is a more specific explanation. I just bought a new ASUS Vivobook s15 s510uq laptop. Of course, I installed Ubuntu on it. I have tried many tutorials and also installed fingerprint-gui as well as fprint, but they don't see any device available.

Below is the output of lsusb:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 8087:0a2b Intel Corp. 
Bus 001 Device 002: ID 13d3:5a07 IMC Networks 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Below is the output of lspci:

00:00.0 Host bridge: Intel Corporation Device 5904 (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Device 5916 (rev 02)
00:04.0 Signal processing controller: Intel Corporation Skylake Processor Thermal Subsystem (rev 02)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller (rev 21)
00:15.1 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Device 9d10 (rev f1)
00:1c.5 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port (rev f1)
00:1e.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO UART Controller (rev 21)
00:1e.2 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO SPI Controller (rev 21)
00:1f.0 ISA bridge: Intel Corporation Device 9d4e (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Device 9d71 (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
01:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 940MX] (rev a2)
02:00.0 Network controller: Intel Corporation Device 24fd (rev 78)

Not sure which one is the fingerprint device. But the case is not only "No devices found". When the screen is locked and I try to unlock it, sometimes in the bottom it shows the notification that I can login using fingerprint. Feels like the fingerprint is detected.

Maybe anyone can help? What can I do with this?

8
  • 2
    I'm sorry telling you that the driver for our fingerprint sensor is not ported for linux until this date. (source: home.ullrich-online.cc/fingerprint/Forum/topic.php?TopicId=615 ) thanks for reading Feb 15, 2018 at 17:24
  • Just looking around, but can't find any solution. Thank you for telling me
    – isatrio
    Feb 16, 2018 at 2:01
  • 1
    Found any solution for this? Its even a year already :(
    – Mg Thar
    Apr 11, 2019 at 18:06
  • Couldn't find any. Even I changed my laptop already
    – isatrio
    Aug 11, 2019 at 16:34
  • any update? I'm having the same prob.
    – Asel
    Mar 28, 2020 at 19:36

1 Answer 1

1

These sensors should be working in the new 1.92 release of libfprint. Not many distributions have incorporated it yet, but you can build it from source.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.