1

Front audio fails to work. Verified audio is enabled in bios. Replaced entire front harware. One interesting observation: If I have headphones plugged into the back (which works fine) and plug a second set into the front (0 audio is audible), the back headphones volume goes way up and the volume control does nothing. Remove the front headphones and the volume and volume control go back to normal for the rear headphones. So there is some signal getting through on the front, but not the audio. Also, Sound under Settings displays Line Out Build-in Audio. When headphones are plugged in to the front port, the Line Out Build-in Audio device changes to Headphones Build-in Audio. Still no audio. Rhythmbox volume is enabled. Tried alsactl, didn't help. Suggestions?

Motherboard Name: GA-AX370-Gaming K7 (rev 1.0) BIOS Ver.: F7a. CPU Model: AMD A10-9700 Radeon R7 Operating System: Ubuntu 17.10

0

https://frdmtoplay.com/gigabyte-front-panel-audio-with-linux/

cut and paste below into a file called audio.sh

usage="usage: sh audio.sh s|h"

in=$(pacmd list-sink-inputs 2>&1 | egrep index: | sed 's/.*: //')

speaker=7

headphone=8

test x"$1" = xs && {

out=$speaker

}

test x"$1" = xh && {

out=$headphone

}

test x"$1" = x && {

echo "$usage"

exit 1

}

pacmd move-sink-input $in $out

  • This answer only allows front or rear audio, not both. Driver needs to be updated so it makes the appropriate changes when the headphones are plugged/unplugged into the front audio. For the time being, this manual process works. – user5930666 Aug 25 '18 at 20:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.