0

My browser crashes every 2 minutes.

How can I make sure in Ubuntu to turn off any Security updates? 100% sure?

6
  • My PC got 100% unusable because of the Intel Bug fixes in the Kernel and elsewere. I am now moving to a new PC but don't want this new PC to also be broken. How can I turn off the security updates? I meant a 100% way to avoid disaster? – mrsteve Jan 13 '18 at 21:27
  • try updating to kernel 4.14 – ravery Jan 13 '18 at 21:29
  • @ravery: What do you recommend to do that? sudo apt-get install --install-recommends xserver-xorg-hwe-16.04? – mrsteve Jan 13 '18 at 21:30
  • 1
    Disabling security updates is trivial to do in the Software and Updates Control...but is most unwise. Your new, unpatched PC, and all your data, may pwned by a malicious actor using a published exploit. – user535733 Jan 13 '18 at 21:39
  • @user535733 Having your PC bricked by Intel via a security update is worse. – mrsteve Jan 13 '18 at 22:04
0

4.14.13 kernels and newer should have the fixes built into them. They may work better then the patched older kernels.

Download the headers and kernel from Ubuntu's mainline daily builds.

For 64-bit:

For 32-bit:

Then, use dpkg to install headers-all, headers-generic, then the kernel. The dpkg command is in the form of sudo dpkg -i <file name>. For example:

sudo dpkg -i linux-image-4.14.13-041413-generic_4.14.13-041413.201801101001_i386.deb

In the terminal you can use tab to complete file names after typing enough characters to identify the file. I.e. linux-i and linux-h should be enough for the autocomplete to work.

Then reboot your system. Do not remove your old kernel until you are confident the new one is working satisfactorily. Personally I keep one old kernel for emergency fall back.

Note: If you are not using an X86 or X86_64 architecture, other kernel debs and source code can be found here: v4.14.13 mainline build

3
  • Although this is a potential solution, just keep in mind the mainline kernel is unsupported. – Panther Jan 14 '18 at 3:11
  • @panther -- Yes I know, but 4.14.13 is the first kernel to have meltdown protection built in and 4.15 should have specter protection. I personally ran 4.14.13 and didn't notice any performance hit; however, I have an AMD system so can not give absolute testimony. – ravery Jan 14 '18 at 4:55
  • Those methods don't work reliably in the current Meldown/Spectre mess. I did exactly that. The 'Grub advanced menu' crashes instantly. – mrsteve Jan 15 '18 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.