17

I cannot transfer photos and videos from the SD card in my phone (Gallaxy S5 Neo). I plug in the phone, tap "Allow" to transfer files and I can then see the phone mounted in Nautilus. I go to Card/DCIM/Camera in Nautilus and the spinning wheel shows up. Then it takes minutes to display the contents of the folder. When I click on one of the files Nautilus freezes and a "force quit" window shows up.

It seems to be related to a recent update as I was able to transfer files on Ubuntu 17.10 before. I've tried rebooting both my phone and my computer. Any suggestions to transfer the files via USB cable?

2
  • 3
    I have the same problem in Xubuntu using nautilus or thunar or even when accessing the files from the command line. Seems to be a problem with the mtp library. If I remove all files with ( or ) braces then loading a large dir is still slow but works. I also did not find any other mitigation so far. One alternative is github.com/whoozle/android-file-transfer-linux. I was able to successfully list and transfer using this tool. However finding and OS-integrated fix would be better.
    – Juve
    Mar 16 '18 at 19:23
  • 1
    I found a related error report here sourceforge.net/p/libmtp/bugs/1765 I guess it the current state libmtp is not usable with many android devices as ...(0).jpg file names are really common after editing files, etc. Note that the above mentioned android-file-transfer (aft) also provides aft-mtp-mount which you can use to mount the device and use your favorite file browser
    – Juve
    Mar 16 '18 at 20:30
15

I have a similar issue with a Galaxy S6. I discovered that some images get filenames with parentheses at the end, like ...(0).jpg. It seems like Nautilus hangs when trying to list those images and ultimately fails. I moved them to a new directory on the phone, and Nautilus was noticeably faster in loading DCIM/Camera directory. I then tried to load the new directory with < 20 images with parentheses and Nautilus failed again. Renaming the files to remove the parentheses fixed everything.

6
  • 1
    how are you supposed to change the filenames?
    – chuse
    Mar 9 '18 at 10:32
  • I renamed them on the phone
    – frenesim
    Aug 26 '18 at 11:09
  • 2
    The problem with parentheses in filenames slowing down folder acces seems still to exist in Ubuntu 18.04
    – maxhb
    May 1 '19 at 6:25
  • 2
    I confirm that the problem is still in Ubuntu 18.04... Oct 9 '19 at 18:36
  • 1
    My problem was finding that one file with parenthesis. I used Gayan's solution (see his answer) and now the folder is instantaneously loading! Mar 2 '20 at 18:26
6
  1. On your android device, tap on "Charging this device via USB" notification.
  2. Under "Use USB for," select "Transfering images" instead of "Transfering Files".

This will allow faster (instant) access to the DCIM folder.

3
  • This helped me to find that one file with parenthesis! How annoying that was... the camera folder was very slow but not showing a file with parenthesis which was "hidden" in a completely different folder. Mar 2 '20 at 18:23
  • It works, but it's a solution only if I don't need to copy other files than images. Apr 18 '20 at 11:56
  • @user2342558 yes. I think it's a bug that needs to be fixed. Let me know if there's a better alternative. Apr 18 '20 at 14:12
4

I had a similar problem with my Galaxy S8 in Ubuntu 18.04. I once clicked the Camera folder, nautilus didn't respond and then even after removing and plugging device back, none of the folders in phone were loading. I removed and reinstalled libmtp, didn't work. Then I removed and reinstalled nautilus, and all folders except DCIM/Camera were working. After moving 20 or so files with "(" and ")" in their names to another folder with file manager on my phone, DCIM/Camera was too opening without any problem.

TL;DR: Get rid of files with parentheses in their name.

If that does not work, try removing and reinstalling nautilus.

1
  • The parenthesis was the culprit, only I don't understand how the system works. Where on Earth was that file... I used Gayan's solution to find the file and delete it. I did not have access to my SDCard while doing so, but in the end it resolved the issue! Mar 2 '20 at 18:25
2

Installing an SSH server onto my phone was easy and has worked surprisingly well. Once the SSH server is started, you can access the files using Nautilus.

Install SSHelper: https://arachnoid.com/android/SSHelper/index.html

Run SSHelper on phone.

Put "Server address" and "SSH server port number" from SSHelper on phone into address bar in Nautilus (e.g., sftp://192.168.0.253:2222).

Nautilus will prompt for username and password (e.g., anonymous & admin).

Remember to stop SSHelper on phone to close SSH port when done.

2
  • I couldn't get Nautilus to work (permission denied reading "/") but I can ssh to the phone (ssh -p 2222 192.168.1.119) .. but it only seems to see a 'SDCard' folder, I cannot access the internal memory, that is normally called 'Phone' in normal USB file transfer. Any tips?
    – Neek
    Feb 7 '20 at 15:32
  • Update: the 'SDCard' folder visible over ssh seems to contain the 'Internal storage' contents, i.e. it is misnamed. I can use Files on the phone to browse, and it's not the SDCard folder that SSHelper shows me. I can now rename my parentheses and access the phone's internal memory (great!) but cannot access the SDCard in the same way to fix the parentheses. Also weirdly, file browser on phone doesn't find any files when searching for "(", when they are there.
    – Neek
    Feb 7 '20 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.