1

How do I make my touchpad working without having to press Window(super)Key? I am using Ubuntu 16.04.3, I don't use mouse. It is working normal before (Without have to press Win Key) when I first installed Ubuntu. But then suddenly about 2 weeks, it was not working that way anymore(just simple tap, double tap or two finger scroll is not working), and I found out that I have to hold on on win key to make my touchpad works. my touchpad is
↳ ETPS/2 Elantech Touchpad id=13 [slave pointer (2)]

after I run: xinput list-props 13: xinput list-proos 13

7
  • I've written an answer here. Let me know if it helps or you have questions by adding a comment below using @WinEunuuchsToUnix in the comment Jan 16, 2018 at 0:52
  • This is what I did. From the article I did do 2 things. first I am running "sudo rmmod psmouse sudo modprobe psmouse" and second I did run "sudo apt-get purge xserver-xorg-input-synaptics" . The result is that I can scroll down the page and my curser did not jump around. So I thought it works then I restart my machine. Apparently all it back to does not working. But I found from article somewhere to install touchpad indicator, and I did this way I guess I set my touchpad to enable . I know it is temporary, and I believe it is better way to do this. Thank you
    – Ja_Jan
    Jan 18, 2018 at 20:47
  • I've posted a permanent fix so that psmouse is removed and inserted with every boot. Try it when you have time and let me know if your system works fine now. Thanks. Jan 19, 2018 at 0:00
  • so I try this time with temporary fix you post ""sudo rmmod psmouse sudo modprobe psmouse" , but it did not work so I am not sure to try permanent fix. BTW, I have installed new kernel 4.14.0-041400-generic on my machine , and I have x86 machine.
    – Ja_Jan
    Jan 21, 2018 at 0:35
  • If the temporary fix doesn't work permanent fix won't either. Kernel 4.14.0-041400-generic is old. You would be better trying the newest kernel 4.14.14-041414-generic to test the fix. Jan 21, 2018 at 19:03

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy