I recently upgraded to virtualbox 5.2.4 and vagrant 2.0.1 because of this issue. Since then, I haven't been able to run any of my vagrant boxes (some ubuntu, some centos). I get the following error when running vagrant up:

There was an error while executing VBoxManage, a CLI used by Vagrant for controlling VirtualBox. The command and stderr is shown below.

Command: ["startvm", "ef47d1fc-4ed1-42cb-b564-09bc2bb43296", "--type", "headless"]

Stderr: VBoxManage: error: The virtual machine 'ishbook-centos' has terminated unexpectedly during startup with exit code 1 (0x1) VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component MachineWrap, interface IMachine

When I just run vboxmanage without --type headless, I get a popup saying to run /sbin/vboxconfig.

RTR3InitEx failed with rc=-1912 (rc=-1912)

The VirtualBox kernel modules do not match this version of VirtualBox. The installation of VirtualBox was apparently not successful. Executing


may correct this. Make sure that you do not mix the OSE version and the PUEL version of VirtualBox.

where: supR3HardenedMainInitRuntime what: 4 VERR_VM_DRIVER_VERSION_MISMATCH (-1912) - The installed support driver doesn't match the version of the user.

No luck even after running sudo /sbin/vboxconfig multiple times.

I've tried reinstalling virtualbox and the extension pack multiple times and reinstalling linux-headers and dkms as seen in answers to questions similar to this one, but nothing has worked. Any ideas?

Edit: Just tried it out on 5.1, but it's the same error, 5.0 just hangs my computer


OK. Figured out the problem here. My kernel modules hadn't been deleted from the previous install of virtualbox when I uninstalled. So when I ran modinfo vboxdrv, it said I was using the kernel drivers for 5.0.4.

I deleted everything in the path to the filename given in the modinfo output and rebooted. Installing virtualbox and starting vms worked after that.

  • 1
    Same thing worked by uninstalling the package virtualbox-dkms and then force-reinstall (or uninstal and install) virtualbox-X.Y – tu-Reinstate Monica-dor duh Jun 10 '19 at 3:35
  • This worked for me in an 5.2 >> 6.1 upgrade – sola Sep 29 '20 at 14:58

I found that a simple uninstall and reinstall of both VirtualBox and Vagrant solved this issue.

Each of the installers come with a uninstall script for convenience. Run this before installing. Ideally from a fresh boot of your system to ensure VirtualBox is not running.

  • I believe this works in most cases, but kernel modules aren't deleted by default and can carry over from previous versions, which is what caused the issue in my case – 1419636215 Sep 28 '18 at 16:23

I faced the same issue, I ran sudo /sbin/vboxconfig command in terminal and after its successful execution, I was able to start the vm.


Try running it with root permissions through sudo:

sudo /sbin/vboxconfig

It worked on my case.

  • I guess I didn't mention that I ran it with sudo in the question. BTW it prompts you for your password on each command anyway. – 1419636215 Jan 15 '18 at 16:18

Just had an issue where a system update clobbered my Virtual XP, giving the "rc=-1912" error, the suggestion of reinstalling, etc. What I found worked was sudo apt-get update sudo apt-get upgrade Seemingly overly simple but worked here!


I had faced the same issue in macOS Mojave 10.14.6 and virtual box

Restart the Mac into Recovery Mode by rebooting and holding down COMMAND + R keys concurrently At the “Utilities” screen, pull down the ‘Utilities’ menu and choose “Terminal” to launch terminal from Recovery Mode Enter the following command:

spctl kext-consent add VB5E2TV963

Hit Return, then restart the Mac with a normal boot as usual

VB5E2TV963 this is the code for Oracle, found it raw but it worked for me...



VBoxManage startvm name --type=headless

Found it here: The virtual machine has terminated unexpectedly during startup because of signal 6.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.