1

wireless info script output: https://drive.google.com/open?id=1fhT2Uy5dGd_SpMelj6WcHtGV7xkVKEis

symptoms:

  • sometimes, after a reboot, wifi is disabled and I cannot enable it
  • sometimes, after a reboot, ubuntu claims it connects to a network but drops after a few seconds/minutes. During the time that ubuntu claims to be connected, I cannot ping 8.8.8.8 and my ubuntu laptop is not in the router's list of connected devices.
  • sometimes, after a reboot, ubuntu tries to connect to my home network but cannot
  • once, after a reboot, the internet was usable for a few hours
  • I cannot reliably connect to any wireless network. A USB connection to my phone does work.

What I tried:

  • Forgetting the network
  • Unplugging and plugging the router back in
  • Disabling random mac address assignment
  • Ubuntu 17.04 (normally I use Ubuntu 16.04)
  • Installing realtek drivers
  • Adding 8.8.8.8 as a DNS
  • Changing IPv6 to "Ignore"
  • Stopping NetworkManager, deleting NetworkManager.state, and starting NetworkManager
  • disbling powersave in /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

I'm not aware of anything I did that triggered this.

In the script output that I linked above, rfkill shows some blocked devices. Currently, rfkill list all returns

1: acer-wireless: Wireless LAN
             Soft blocked: no
             Hoft blocked: no
2: acer-bluetooth: Bluetooth
             Soft blocked: no
             Hoft blocked: no
3: hci0: Bluetooth
             Soft blocked: no
             Hoft blocked: no

and ping 8.8.8.8 returns connect: Network is unreachable.

Also, dmesg has different output now then when I ran the script. Now there's a line iwlwifi 0000:03:00.0: Failed to run INIT ucode: -110 which isn't in the script output, for example.

NetworkManager.state is also different now vs. when I ran the script. Now it's

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
0

I had somewhat similar problems but Power Management stuff worked for me. Every time the signal power of the Wifi (to which my device was connected) dropped, the device just disconnected from the network. Hope it works for you too.

To turn off the Power Management, first check output of the iwconfig command.

$ iwconfig

enp7s0    no wireless extensions.

lo        no wireless extensions.

wlp6s0    IEEE 802.11abgn  ESSID:"Avni.LoveLace"  
          Mode:Managed  Frequency:2.442 GHz  Access Point: C8:D7:79:A1:CE:E4   
          Bit Rate=72.2 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=61/70  Signal level=-49 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:722   Missed beacon:0

Look for Power Management:on, then turn it off by typing

iwconfig wlp6s0 power off

where wlp6s0 is the wireless interface.

It sometimes works sometimes not. If this doesn't helps you, you need to change the Network Configurations for Power Management.

  1. Editing powersave values in /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

    Possible values of powersave are:

    NM_SETTING_WIRELESS_POWERSAVE_DEFAULT (0): use the default value
    NM_SETTING_WIRELESS_POWERSAVE_IGNORE (1): don't touch existing setting
    NM_SETTING_WIRELESS_POWERSAVE_DISABLE (2): disable powersave
    NM_SETTING_WIRELESS_POWERSAVE_ENABLE (3): enable powersave
    

    Open the file and edit powersave value from whatever it is to 2. That will disable the powersave. By default there is

    wifi.powersave = 3
    

    Just change it to a value of 2.

    wifi.powersave = 2
    

    Save it and Reboot the System and you're done !

  2. Creating a blacklist file for Wireless Power Management

    This is well explained by @sagarchalise 's answer on the topic

I think one of these method should work for you, If it's something wrong with Wireless Power Management. If not, then feel free to edit to add more stuff into it.

  • I tried method 1, that you suggested. iwconfig now consistently shows Power Management:off, so I did succeed in changed something. No effect on the symptoms, though. – Erik Wyatt Jan 14 '18 at 19:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.