0

I have a Dell Inspiron 15 7000 and I installed Ubuntu in /dev/sda. Sadly once the operation is completed if I try to use boot-repair it says EFI partition is not found.

I'm pretty sure I have to install as I did, in legacy..because I own a UEFI system but apparently a legacy Windows 10. Still in my BIOS I can't retrace Windows boot manager, I tried with bootmngr.efi but to the system it looks like there is no boot device avilable. By now it boots as partition 1. Disk 1 is where Windows OS is installed, I instead installed Ubuntu on disk 0. Can someone tell me if this is the actual problem? I decided to install on disk 0 because there's much more space in there. If i type sudo parted -l the result is

Model: ATA ST1000LM035-1RK1 (scsi) Disk /dev/sda: 1000GB Sector size (logical/physical): 512B/4096B Partition Table: gpt Disk Flags:

Number Start End Size File system Name Flags 1 1049kB 135MB 134MB Microsoft reserved partition msftres 2 135MB 1000GB 1000GB ntfs Basic data partition msftdata

Model: SCSI DISK (scsi) Disk /dev/sdb: 16.0GB Sector size (logical/physical): 512B/512B Partition Table: msdos Disk Flags:

Number Start End Size Type File system Flags 1 1049kB 16.0GB 16.0GB primary fat32 boot, lba

But if i try to install ubuntu in uefi mode a windows pops up stating This machine's firmware has started the installer in UEFI mode but it looks like there may be existing operating systems already installed using "BIOS compatibility mode". If you continue to install Debian in UEFI mode, it might be difficult to reboot the machine into any BIOS-mode operating systems later. This is weird considering that according to the system settings the bios is UEFI.

  • If you system was purchased from Dell with Windows 10 (or 8) then it has to be UEFI. post this in your question above: sudo parted -l – oldfred Jan 12 '18 at 15:37
  • should i select a gpt partition for uefi computer? – Mario Bernardi Jan 12 '18 at 16:36
  • You have gpt on sda & MBR(msdos) on sdb. Better if all drives are gpt if you want UEFI. But sda only has the required Windows msftres/Microsoft reserved partition. Did you erase Windows? If also re-installing Windows do that first as it wants several partitions. askubuntu.com/questions/743095/… & askubuntu.com/questions/343268/… – oldfred Jan 12 '18 at 17:51
  • well..no i'm using Windows right now!! I know perfectly how the partition works..but i don't get why i get errors installing uefi, and installing Legacy i couldn't access ubuntu. – Mario Bernardi Jan 12 '18 at 17:59
  • The reason why you see just a partition i think/hope is due just to the fact that i shrinked that volume. I tried to use Rufus to have gpt in dev/sdb but keep getting the same error – Mario Bernardi Jan 12 '18 at 18:58

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.