DP1 displaying correctly:

DP1 displaying correctly

eDP1 with corrupt display:

eDP1 with corrupt display

My new machine has two monitors connected directly to the motherboard (using DisplayPort I think - they are identified as eDP1 and DP1). My issue is that the primary monitor becomes corrupted when the boot up sequence screen starts and I haven't found any way to recover/configure to avoid this happening. The screen is not freezing but is unusable (see images).

Both monitors work correctly if I boot into Windows and when I boot from a liveUSB, both monitors mirror each other until the ubuntu boot splash at which point, the first monitor becomes corrupted and garbled.

I have external ports for VGA and HDMI, both of which work correctly for multi monitor but I haven't been able to identify why the first monitor doesn't work. Unfortunately, the main monitors are built in with connections directly on the motherboard, so I'm not able to connect these to the external VGA/HDMI ports.

When I run Xrandr, the monitors report as eDP1 and DP1. I've set a range of different resolutions and enabled screen mirroring. I tried a number of liveUSB versions and distros including Ubuntu 16.04, 17.10, Lubuntu 14.04, ArchLinux and Linux Mint. I have also tried some different BIOS configurations. All to no avail. I haven't been able to find any errors reported in syslog, dmesg or Xorg logs.

At this point, I'm a little lost as to what my next steps should be.

Any help or suggestions would be much appreciated.

The machine is running the Intel Core i3 4010U (Haswell) with Intel Graphics and 8GB RAM.

The following is reported in Xorg.0.log:

[     5.523] (II) LoadModule: "glx"
[     5.524] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[     5.530] (II) Module glx: vendor="X.Org Foundation"
[     5.530]    compiled for 1.17.2, module version = 1.0.0
[     5.530]    ABI class: X.Org Server Extension, version 9.0
[     5.530] (==) AIGLX enabled
[     5.530] (II) LoadModule: "intel"
[     5.530] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[     5.531] (II) Module intel: vendor="X.Org Foundation"
[     5.531]    compiled for 1.17.2, module version = 2.99.917
[     5.531]    Module class: X.Org Video Driver
[     5.531]    ABI class: X.Org Video Driver, version 19.0
[     5.531] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
    i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
    915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
    Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
    GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[     5.532] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[     5.532] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[     5.532] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[     5.532] (++) using VT number 7

[     5.532] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20150522
[     5.532] (II) intel(0): SNA compiled: xserver-xorg-video-intel-lts-wily 2:2.99.917+git20150808-0ubuntu4~trusty2 (Adam Conrad <adconrad@ubuntu.com>)
[     5.532] (II) intel(0): SNA compiled for use with valgrind
[     5.532] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 4400
[     5.532] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2; using a maximum of 2 threads
[     5.532] (II) intel(0): Creating default Display subsection in Screen section
    "Default Screen Section" for depth/fbbpp 24/32
[     5.532] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[     5.532] (==) intel(0): RGB weight 888
[     5.532] (==) intel(0): Default visual is TrueColor
[     5.532] (**) intel(0): Option "AccelMethod" "sna"
[     5.532] (**) intel(0): Option "Tiling" "true"
[     5.532] (**) intel(0): Option "PageFlip" "true"
[     5.532] (**) intel(0): Option "TripleBuffer" "true"
[     5.532] (**) intel(0): Option "TearFree" "true"
[     5.532] (II) intel(0): Output eDP1 has no monitor section
[     5.552] (--) intel(0): Found backlight control interface intel_backlight (type 'raw') for output eDP1
[     5.552] (II) intel(0): Enabled output eDP1
[     5.552] (II) intel(0): Output HDMI1 has no monitor section
[     5.552] (II) intel(0): Enabled output HDMI1
[     5.552] (II) intel(0): Output DP1 has no monitor section
[     5.552] (II) intel(0): Enabled output DP1
[     5.552] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[     5.552] (II) intel(0): Output VIRTUAL1 has no monitor section
[     5.552] (II) intel(0): Enabled output VIRTUAL1
[     5.552] (--) intel(0): Output eDP1 using initial mode 1920x1080 on pipe 1
[     5.552] (--) intel(0): Output DP1 using initial mode 1280x800 on pipe 0
[     5.552] (**) intel(0): TearFree enabled
[     5.552] (==) intel(0): DPI set to (96, 96)
[     5.552] (II) Loading sub module "dri2"
[     5.552] (II) LoadModule: "dri2"
[     5.552] (II) Module "dri2" already built-in
[     5.552] (II) Loading sub module "present"
[     5.552] (II) LoadModule: "present"
[     5.552] (II) Module "present" already built-in
[     5.552] (==) Depth 24 pixmap format is 32 bpp
[     5.552] (II) intel(0): SNA initialized with Haswell (gen7.5, gt2) backend
[     5.552] (==) intel(0): Backing store enabled
[     5.552] (==) intel(0): Silken mouse enabled
[     5.552] (II) intel(0): HW Cursor enabled
[     5.552] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[     5.553] (==) intel(0): DPMS enabled
[     5.553] (==) intel(0): Display hotplug detection enabled
[     5.553] (II) intel(0): [DRI2] Setup complete
[     5.553] (II) intel(0): [DRI2]   DRI driver: i965
[     5.553] (II) intel(0): [DRI2]   VDPAU driver: va_gl
[     5.553] (II) intel(0): direct rendering: DRI2 enabled
[     5.553] (II) intel(0): hardware support for Present enabled
[     5.553] (WW) intel(0): Option "MigrationHeuristic" is not used
[     5.553] (WW) intel(0): Option "ExaNoComposite" is not used
[     5.553] (--) RandR disabled
[     5.569] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[     5.569] (II) AIGLX: enabled GLX_ARB_create_context
[     5.569] (II) AIGLX: enabled GLX_ARB_create_context_profile
[     5.569] (II) AIGLX: enabled GLX_EXT_create_context_es2_profile
[     5.569] (II) AIGLX: enabled GLX_INTEL_swap_event
[     5.569] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[     5.569] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[     5.569] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[     5.569] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[     5.569] (II) AIGLX: enabled GLX_ARB_create_context_robustness
[     5.569] (II) AIGLX: Loaded and initialized i965
[     5.569] (II) GLX: Initialized DRI2 GL provider for screen 0
[     5.572] (II) intel(0): switch to mode 1280x800@60.0 on DP1 using pipe 0, position (0, 0), rotation normal, reflection none
[     5.572] (II) intel(0): switch to mode 1920x1080@60.0 on eDP1 using pipe 1, position (0, 0), rotation normal, reflection none
[     5.572] (II) intel(0): Setting screen physical size to 508 x 285

If you are still trying...

The ugly monitor is detected with resolution 1200x800. That is why it looks bad. The interesting question is whether your video card is capable of driving both monitors.

I would try

  1. install arandr and manually dial up resolution

If that is a fail, suspect the video is not capable.

  1. disconnect 'good' monitor, start pc on bad one. If it becomes good, you have some information. Then plug in other monitor. What happens?

Show us output from xdpyinfo

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.