1

I have attached wifi troubleshooting script output for

1) new where wifi does not work

2) old kernel where wifi works

I've booted to the previous version and tried

sudo apt-get update && sudo apt-get dist-upgrade

but no change.

EDIT (solved): I've used driver version from https://github.com/gnab/rtl8812au using steps given below by @chili555. Now works with kernel 4.13...

4
  • 1
    An easy and perhaps obvious workaround would be to boot using the 4.10.0-42-generic kernel that was working before to verify that it's still functional for you. This would have the positive effect of confirming that your issue is indeed related to the new kernel rather than something else.
    – Elder Geek
    Jan 11, 2018 at 17:48
  • Ubuntu 16.04 isn't a development version so close reason shouldn't apply. Also Kernel 4.13.0-26 is part of Hardware Stack that many users are subscribed to: launchpad.net/ubuntu/+source/linux-hwe/4.13.0-26.29~16.04.2 Jan 12, 2018 at 1:49
  • 1
    @WinEunuuchs2Unix: I doesn't help that OP doesn't ask any kind of question just "look at this issue that I have" which indeed sounds like a bug report and not a request for help. Jan 12, 2018 at 10:15
  • @DavidFoerster I would automatically agree except that Chili5555 had written an answer potentially solving the problem when I stumbled across this closed question. Jan 12, 2018 at 11:05

2 Answers 2

3

There is apparently a bug in the code for the rtl8812 (the wifi that you have) and the module does not build correctly in the new kernel

Please see https://bugs.launchpad.net/ubuntu/+source/rtl8812au/+bug/1742426

I would encourage you to add your name to the list of people who have this problem, as you will receive mail when someone is working on the subject, and they may find a work around or ask you to test something to assist in debugging the problem.

2
  • Thank you for an explanation. I've also subscribed as you have advised.
    – hotbit
    Jan 11, 2018 at 15:44
  • The more people who attach themselves to that particular problem, the more attention it may receive! Jan 11, 2018 at 15:45
1

I suggest that you try a different driver package. First, remove the package that won’t compile:

sudo apt purge rtl8812au-dkms

Next, do:

sudo apt update
sudo apt install git
git clone https://github.com/gnab/rtl8812au.git
sudo cp -r rtl8812au  /usr/src/rtl8812au-4.2.2
sudo dkms add -m rtl8812au -v 4.2.2
sudo dkms build -m rtl8812au -v 4.2.2
sudo dkms install -m rtl8812au -v 4.2.2

Reboot and tell us if the wireless is working.

1
  • Hi, finally I've managed to find some time to move computer and connect via cable. I've missed the 1st line, still solution works like a charm. (already kernel kernel 4.13.0-32 instead of kernel 4.13.0-26). Thank you!
    – hotbit
    Jan 31, 2018 at 22:26

Not the answer you're looking for? Browse other questions tagged .