0

I installed Xubuntu 16.04 in my HP 245 G2 laptop, and everything works fine but the WiFi. I have a Qualcomm Atheros 9565 WiFi card and Xubuntu tells me that WiFi is disabled. I had the same problem with Ubuntu and a live USB drive with Linux Mint.

When I press F12, the WiFi light indicator turns red (off) for a millisecond and then turns back to the white light (on).

Ubuntu supposedly comes with the default drivers for the card so I didn't install anything.

Here is the output of a few commands:

$ sudo rfkill unblock all
$ sudo rfkill list
0: hp-wifi: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes
1: hp-bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: yes
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
$ sudo modprobe ath9k && dmesg | grep ath
[   23.046369] ath: phy0: WB335 1-ANT card detected
[   23.046375] ath: phy0: Set BT/WLAN RX diversity capability
[   23.061786] ath: phy0: Enable LNA combining
[   23.065354] ath: phy0: ASPM enabled: 0x43
[   23.065362] ath: EEPROM regdomain: 0x6a
[   23.065364] ath: EEPROM indicates we should expect a direct regpair map
[   23.065369] ath: Country alpha2 being used: 00
[   23.065371] ath: Regpair used: 0x6a
[   23.356577] usbcore: registered new interface driver ath3k
[   24.164539] ath9k 0000:03:00.0 wlo1: renamed from wlan0
  • Please don't edit your question to mark it solved or to add a solution. Instead, add an answer below (in the answers section) and mark the question solved by clicking the checkmark next to your answer. – Chai T. Rex Jan 12 '18 at 23:00
0

i solved the problem by running in terminal:

sudo tee /etc/modprobe.d/blacklist-hp.conf <<< "blacklist hp_wmi"

and after a reboot the wifi works!!!

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.