3

I have searched through many questions on this forum and still do not feel like I can find an answer specific to my computer. The only answer that I found that came close was this one:

Qualcomm Atheros Device 0042 (rev 31) driver

however it seems that all links on the page are broken. I have tried following the detailed instructions on this page:

Qualcomm Atheros Device [168c:0042] (rev 30) Wi-Fi driver installation

however it does not work, I imagine because I am rev 31 rather than 30.

I am very lost, please help!! As far as I understand the process is the same, I just need a different link. Could someone find that link for me?

Thank you so much!

Michele

0
4

With a working internet connection by ethernet, tethered or whatever means possible, please open a terminal and do:

sudo apt-get update
sudo apt-get install git
git clone https://github.com/kvalo/ath10k-firmware.git
sudo mkdir /lib/firmware/ath10k/QCA9377
sudo mkdir /lib/firmware/ath10k/QCA9377/hw1.0
cd ath10k-firmware/QCA9377/hw1.0
sudo cp *  /lib/firmware/ath10k/QCA9377/hw1.0
cd /lib/firmware/ath10k/QCA9377/hw1.0
sudo mv firmware-5.bin_WLAN.TF.1.0-00267-1  firmware-5.bin

Reboot and your wireless should be working.

7
  • Hi! Thank you very much for the help. I did everything up until the last line, but then got the error: 'mv: cannot stat ‘firmware-5.bin_WLAN.TF.1.0-00267-1’: No such file or directory' – Michele Jan 12 '18 at 18:57
  • I searched for a file called firmware-5.bin_WLAN.TF.1.0-00267-1 but couldn't find one anywhere. I have a file called 'firmware-5.bin_CNSS.TF.1.0-00267-QCATFSWPZ-1' In the CNSS.TF.1.0 directory, and other files with different numbers in other directories, but none exactly like that – Michele Jan 12 '18 at 19:00
  • Update: I got it to work!!! I was just fooling around testing the 3 files that I did have. I ended up copying the file from in CNSS.TF.1.0 into hw1.0 and renaming it firmware-5.bin using the command: 'sudo cp CNSS.TF.1.0/firmware-5.bin_CNSS.TF.1.0-00267-QCATFSWPZ-1 firmware-5.bin'. I rebooted and it was working!! Please let me know if this would cause any other problems. – Michele Jan 12 '18 at 19:10
  • As a note, I needed to add a -r to the sudo cp command in order to get it to work as well or else it was omitting the directories inside. Thank you very much for your help!! – Michele Jan 12 '18 at 19:11
  • okk great . Now do sudo apt update ; sudo apt upgrade – burhanuddin abbas Jan 13 '18 at 6:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.