1

I have tried a machine with Ubuntu 16.04 32- and 64-bit and Ubuntu 17.10 64-bit several times. Intel Virtualisation is enabled in BIOS. Secure boot is disabled. It happens on kernels 4.13.0-26-generic and 4.13.0-31-generic. Maybe it has something to do with the fact that I installed and purged gnome-boxes earlier. An example of a consequence of that is that a system user Libvirt Qemu still appears on the login screen and I am afraid that removing it might break something. Interestingly, VirtualBox seemed to work well when I installed it inside an Ubuntu 16.04 virtual machine in the aforementioned gnome-boxes although unsurprisingly the machines run by it were very slow.

  • this is happening to me trying to use rawdisk for a simple Windows 10 guest VM. VirtualBox just immediately freezes the whole host (elementary OS / xenial). – Nathan Beach Jan 14 '18 at 17:08
1

Same here, solved by installing Virtualbox 5.1.30 from the website.

  • If you install it from the website, do you then get automatic updates? Or do you need to install it from the website again every time you want to update it? – geras Jan 17 '18 at 16:29
  • @geras You have to go update it yourself - you won't get automatic updates. unless they started serving their own VirtualBox repository with updates in it, and that's added, but I doubt they have that. – Thomas Ward Jan 24 '18 at 19:57
  • 1
    @ThomasWard I have actually managed to add a repository and install VirtualBox 5.2.6 from there as described here: virtualbox.org/wiki/Linux_Downloads in section "Debian-based Linux distributions" so I believe I should be getting automatic updates with Software Updater. – geras Jan 25 '18 at 23:04
3

I had the same Problem after upgrading my Kernel to 4.13.0-26-generic I selected my previous Kernel 4.10.0-42-generic in grub on boot time and it worked.

My guess is that there is a problem in the most recent Kernel. (4.13.0-26 at the time of this writing) Problem is, that is the one with a Patch for the vulnerability CVE-2017-5754 (Meltdown).

  • I think it didn't work for me, although I'm not entirely sure if I did it correctly and now for some reason I am unable access the grub menu so I can't check it again. – geras Jan 23 '18 at 20:44
  • Related: askubuntu.com/questions/995819/… – WinEunuuchs2Unix Jan 31 '18 at 13:42
1

This happened to me too. I had to install Virtual Box 5.2.6 and after that I had no problem running vms. However, I did have an issue with Virtual Box 5.2.6 and my iwlwifi driver on my laptop. The computer would just randomly hang. Took me a few days to figure out. Had no problem with other wifi adapter using other drivers. There was an issue with kernel 4.14 with Virtual Box 5.2.6 and iwlwifi. I had no issues prior to the new kernel with the older version of VB

0

You can solve this by installing a lower version of virtualbox or the latest version of vmware, or still, downgrade your kernel.

0

From https://superuser.com/questions/1284924/virtualbox-freezes-my-host-system-ubuntu-16-04/1305277#1305277 :

This seems to be Bug #1736116 "[SRU] Host with kernel 4.13 freezes when starting a VM with VirtualBox"

There is now a fix in the virtualbox packages version 5.1.34, available in the in the xenial-proposed repository, and hopefully soon in the main repository.

For a quick copy/paste solution, this worked for me:

echo "deb http://archive.ubuntu.com/ubuntu/ xenial-proposed restricted main multiverse universe" \
| sudo tee -a /etc/apt/sources.list.d/ubuntu-proposed.list

echo "Package: *"                     | sudo tee -a /etc/apt/preferences.d/proposed-updates
echo "Pin: release a=xenial-proposed" | sudo tee -a /etc/apt/preferences.d/proposed-updates
echo "Pin-Priority: 400"              | sudo tee -a /etc/apt/preferences.d/proposed-updates

sudo apt update

sudo apt-get -t xenial-proposed install virtualbox virtualbox-dkms virtualbox-guest-additions-iso

Once the packages are moved from xenial-proposed to the main repository, you can

sudo rm /etc/apt/sources.list.d/ubuntu-proposed.list /etc/apt/preferences.d/proposed-updates

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.