So my server is at

the client is at

(Both machines have a user called 'work')

On the server, my USB HDD auto mounts as /media/work/EXT4-4TB

I'd like to access this from the nfs client, so, on the server my /etc/exports contains:


To start the nfs server I run:

$ sudo systemctl start nfs-kernel-server.service

On the client I have an empty directory set up at /home/work/archive/

But when I try and access the share with:

$ sudo mount /home/work/archive/

I get:

mount.nfs: access denied by server while mounting

I can access other nfs shared directories on this server, but the difference seems to be that this one is over USB.

I'm thinking it's something to do with the auto-mount or permissions but am out of ideas at this point on how to fix the problem.

Help would be appreciated.

  • 1
    I just noticed your paths are wrong after posting my response below. You are exporting /media/work/EXT4-4TB but on your client you are trying to mount /home/work/EXT4-4TB. You can mount the USB in fstab into /home/workusing step #2 in my response below. Try using sudo mount on the client as well if you want to narrow down the source of the problem. – m_krsic Jan 10 '18 at 16:25
  • Embarrassing. That was the problem :( – Thorsen Jan 10 '18 at 20:06

Try the following

  1. sudo blkid to get the UUID of the USB drive
  2. Add an entry to /etc/fstab to make the drive mount the same way every time, use the UUID instead of the /dev/sdX path, mount it in /mnt instead of the temporary /media folder
  3. Add the new mount path to your /etc/exports
  4. sudo exportfs -ra to load the new NFS settings
  • 1
    Although, my typo was to blame, this looks like a better way to deal with this. I will mark the question as answered. Thank you for the help. – Thorsen Jan 10 '18 at 20:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.