Ubuntu 16.04 LTS Virtualbox 5.0.40 ubuntu r 115130

Today after upgrading to kernel 4.13.0-26 guest vbox machines started to crash whole ubuntu. just hard poweroff is working.

If I startup with kernel 4.10.0-42 everything works fine.

what may be the problem ?

  • 2
    Possibly related: askubuntu.com/questions/994067/…
    – Melebius
    Jan 10, 2018 at 14:08
  • Ubuntu was patched on 1/9/2018 to fix the Meltdown Security hole. Apparently the patch was rushed out and it caused a kernel panic (system crash). It was fixed the next day 1/10/2018 and all reports are things are ok. You can boot with grub and select Advanced Options then pick older kernel version. You can run sudo apt upgrade from the terminal and get the latest kernel which should work fine. Jan 11, 2018 at 2:28
  • 2
    Thank you for detailed explanation. I did boot with older kernel, run "sudo apt upgrade". It outputs "0 packages to upgrade". I have updated repo address to main servers, still same.
    – jemjem
    Jan 11, 2018 at 7:57
  • I also tried "sudo apt upgrade" and the problem still persists.
    – BillMan
    Jan 15, 2018 at 16:49

2 Answers 2


Virtualbox 5.0.40 is not working with the new kernel (4.13.0-26), but the new version of VBox (5.2) works fine.

Download it from VirtualBox page or add the source to your /etc/apt/sources.list:

deb http://download.virtualbox.org/virtualbox/debian xenial contrib

If you use a different version of Ubuntu than 16.04, use the appropriate name instead of xenial.

Add Oracle public key:

wget -q https://www.virtualbox.org/download/oracle_vbox_2016.asc -O- | sudo apt-key add -

Update repositories and install virtualbox-5.2:

sudo apt-get update
sudo apt-get install virtualbox-5.2

On one of my laptops, VM didn't want to start before I removed virutalbox-dkms:

sudo apt-get remove virtualbox-dkms

After the update, I had a problem after starting the virtual-machine (see VirtualBox - RTR3InitEx failed with rc=-1912 (rc=-1912)). As suggested in the first comment, it had been fixed with the following call:

sudo /sbin/vboxconfig
  • 1
    I think it is /etc/apt/sources.list instead of /etc/sources.list
    – oceanBT
    Jan 17, 2018 at 12:26
  • 2
    You are right. I corrected in the original answer. Jan 17, 2018 at 15:30
  • as a note, I had a existing virtual machine with USB support enabled, I had to disable it in order to get the VM started, the Guest Additions package seems to be incompatible.
    – vhax
    Jan 23, 2018 at 21:30

There is already a bug report on launchpad. https://bugs.launchpad.net/ubuntu/+source/virtualbox/+bug/1736116

It is our best shot to get this bug fixed.

Temporary, we can

  • boot the old kernel 4.10.0-42 from the grub menu (not recommended)
  • boot the latest 4.4 LTS kernel from the grub menu, which is still getting security patches

    If it is not already installed: sudo apt install linux-generic


  • upgrade virtualbox from the oracle sources

Not the answer you're looking for? Browse other questions tagged .