0

I would like to install Microsoft Office 2010 as I need urgently excel2010. I installed PlayonLinux but I receive an error. I then try to install wine but I have some weird error output as well. Here is the output, I have already try the command apt --fix-broken install:

sudo apt-get install wine
Reading package lists... Done
Building dependency tree       
Reading state information... Done
wine is already the newest version (1.4-0ubuntu4).
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 wine1.4 : Depends: wine1.4-amd64 (= 1.4-0ubuntu4)
           Recommends: ttf-droid
           Recommends: ttf-liberation
           Recommends: ttf-umefont but it is not going to be installed
           Recommends: ttf-unfonts-core but it is not going to be installed
           Recommends: ttf-wqy-microhei
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Unfortunately, it does not work:

sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  corsix-th-data game-data-packager game-data-packager-runtime libdrm-common
  liblua5.2-0 libsdl2-mixer-2.0-0 libwine lua-filesystem lua-lpeg
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  wine1.4-amd64
Recommended packages:
  wine-gecko1.4
The following NEW packages will be installed:
  wine1.4-amd64
0 upgraded, 1 newly installed, 0 to remove and 5 not upgraded.
4 not fully installed or removed.
Need to get 0 B/21,4 MB of archives.
After this operation, 111 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
WARNING: The following packages cannot be authenticated!
  wine1.4-amd64
Install these packages without verification? [y/N] y
(Reading database ... 258289 files and directories currently installed.)
Preparing to unpack .../wine1.4-amd64_1.4-0ubuntu4_amd64.deb ...
Unpacking wine1.4-amd64 (1.4-0ubuntu4) ...
dpkg: error processing archive /var/cache/apt/archives/wine1.4-amd64_1.4-0ubuntu4_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/wine/propsys.dll.so', which is also in package libwine:amd64 1.8.7-1ubuntu1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/wine1.4-amd64_1.4-0ubuntu4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I found the error, I had my mirror servers set to a different server rather then the main one. What I did was to remove such source in the /etc/apt/sources.list through the following command sudo gedit /etc/apt/sources.list. I run the usual commands such as sudo apt --fix-broken install and sudo apt-get update && sudo apt-get dist-upgrade reinstalled Wine and Playonlinux and everything worked!! thanks!

1 Answer 1

0

Execute below commands

sudo apt --fix-broken install sudo apt-get update sudo apt-get upgrade sudo apt-get install wine

I think this will install wine properly!

4
  • It does not work, I edited the original post with the output the command provided me. Commented Jan 10, 2018 at 13:09
  • Have you update and upgrade the repo by following the those last two commands? Looks like it's trying to install wine1.4-amd64 instead of wine-gecko1.4. I think you are running Ubuntu 12.04? Please specify which Ubuntu version are you using. Commented Jan 10, 2018 at 13:29
  • I have run them all several times. I am running 17.04 but I restored this pc and I used to have installed Wine before, maybe there is some trace from the previous restore. Commented Jan 10, 2018 at 13:37
  • OK, I think there are still some dependencies present of previous wine. Please remove them by using sudo apt-get purge --auto-remove wine and freshly install new wine. Add the new wine repo sudo apt-add-repository 'https://dl.winehq.org/wine-builds/ubuntu/ then download and add wine security repo key wget https://dl.winehq.org/wine-builds/Release.key && sudo apt-key add Release.key and finally install stable version of wine sudo apt update && sudo apt install winehq-stable Commented Jan 10, 2018 at 13:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .