2

I installed Ubuntu 17.10 successfully in dualbot with Win10. It works for a while. But now it does not start.

Description:

When I select Ubuntu in Grub, it starts writing messages into console - standard procedure before the Ubuntu load screen appears. But before the loading screen displays, it stuck in black screen. Few "console like" messages appears instead of black screen in random intervals, but only for such a short time that it is impossible to read it. However it seems that there is no error or important message.

Occurence:

I am not sure why it starts, probably installation of some updates. It works few times after If I choose to load system with older Kernel. Now it does not load always, no matter what kernel is selected.

What I tried:

I tried to repair packages with advanced options in grub. It seems to finish corectly, but system still does not load.

UPDATE:

My friend has the same problem now. The fix was to boot with older Kernel. So it seems that new linux kernel cause to problem with Ubuntu 17.10.

However I cannot do this fix because I already do not have to working Kernel (someone <16 probably). The Kernels I have:

  • 4.13.0-25-generic
  • 4.13.0-21-generic
  • 4.13.0-19-generic
  • 4.13.0-16-generic

How to install it?

I tried:

I logged into root console with recovery mode option and remout the filesystem to enable apt:

mount -o rw,remount /

After I check the list of available Kernels and try to install older one:

sudo apt-get update
sudo apt-get install linux-image-4.13.0-15-generic 

I get the "unable to locate package" error. No matter what version of core I tried. I find out that it is because of a lack of Internet - I verified this with pinging google.

So I tried "network" option in Recovery Menu - no change, still not working.

After I tried How to connect to internet from recovery mode? However I stuck on:

sudo cp /etc/resolv.conf /mnt/etc/
  • cp: cannot stat 'etc/resolv.conf': No such file or directory

How to fix this?

How to enable internet in recovery console?

How to install older Kernel correctly?

How to update GRUB without screwing it?

Thanks for any advice.

  • @Melebius I studied this research of blackcreens, but it does not help. – matousc Jan 11 '18 at 6:43
  • With the additional information, it looks more like a duplicate of askubuntu.com/questions/994067/…. Please check it. – Melebius Jan 11 '18 at 6:50
  • @Melebius Yes, but the difference is that I already do not have the working Kernel. So the given answers does not apply for my case. – matousc Jan 11 '18 at 6:54
  • You should provide more information on your configuration. You should not be able to install linux-image-3.5.0-15-generic at all since it’s way too old for Ubuntu 17.10! Could you post your list of available kernels? AFAIK a working kernel is also necessary for the root console, so I guess you have at least one working kernel. – Melebius Jan 11 '18 at 7:10
  • @Melebius Sorry, the old Kernel was typo. Corrected. I also attached the list of Kernels I have. I can get to recovery mode for every one of listed Kernels. – matousc Jan 11 '18 at 8:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.