0

I am attempting to install ubuntu on a 17" HP Envy laptop. I believe the model is ae000. However, despite my best efforts (I have conducted many google searches and tried multiple answers from other questions here), I am unable to get the wifi to work.

Some diagnostics that may help:

$ lspci -knn | grep Net -A3
03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:b822]
        Subsystem: Hewlett-Packard Company Device [103c:831b]
04:00.0 Non-Volatile memory controller [0108]: Samsung Electronics Co Ltd Device [144d:a804]
        Subsystem: Samsung Electronics Co Ltd Device [144d:a801]

$ rfkill list all
0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

$ iwconfig
lo        no wireless extensions.

enp2s0f1  no wireless extensions.

$ sudo lshw -class network
  *-network               
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0.1
       bus info: pci@0000:02:00.1
       logical name: enp2s0f1
       version: 12
       serial: 48:ba:4e:92:48:e6
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8411-2_0.0.1 07/08/13 ip=10.0.0.4 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:130 ioport:4000(size=256) memory:b4204000-b4204fff memory:b4200000-b4203fff
  *-network UNCLAIMED
       description: Network controller
       product: Realtek Semiconductor Co., Ltd.
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: ioport:3000(size=256) memory:b4100000-b410ffff

Any help is greatly appreciated.

  • Please edit your question and add output of lspci -knn | grep Net -A3 terminal command. Meanwhile test it with Secure Boot disabled. – user692175 Jan 10 '18 at 10:50
  • I have updated the question with the requested output. I thought I had already disabled secure boot, but double checked and it does appear to be disabled. – toadjamb Jan 10 '18 at 17:15
0

tldr: I installed the rtl8822be driver from synthtc/rtlwifi-next. (Secure boot must also be turned off, but I knew to do that).

The bigger problem I was having was that I had no idea what driver I needed. I could not for the life of me figure out what card I had while running ubuntu. So I actually installed windows 10 to make sure the wireless card worked at all and it reported that I have an rtl8822be.

Armed with that knowledge, I then tracked down rtlwifi repos that had that driver (there are a number of rtlwifi repos - they do not all have the same drivers). The first one I tried had a couple errors that an issue in the repo suggested was fixed by a different repo (the one I linked at the top).

git clone https://github.com/synthtc/rtlwifi-next
cd rtlwifi-next
sudo make install
sudo modprobe -r rtl8822be
# make sure secure boot is turned off or the next line will fail
sudo modprobe rtl8822be

For others that may have similar issues, I still have some minor issues connecting to my wifi, but have figured out a way to get it to work. The problem I was originally asking about has been sufficiently resolved, though.

0

Update for 18.04

The Realtek RTL8822BE is supposed to work out of the box in Ubuntu 18.04.

  • During installation, Ubuntu should detect what Wifi Card you have and install the correct driver for it, but to search for any further available drivers on Ubuntu 18.04, go to the Software & Updates program and click the Additional Drivers tab.

(If you're having trouble finding 'Software & Updates', clicking 'Activities' in the top left of your desktop and typing 's' in the search box should be enough to show the available relevant programs)

  • Another occasional 'quirk' that has occurred is for Secure Boot to have an issue with the signing of the driver and preventing it from being loaded.

You can make sure that Secure Boot is disabled by checking your machine's BIOS settings (usually accessed by pressing a specific key chosen by your manufacturer, such as f2 or esc when you switch your computer on, but the Grub Menu also lets you select 'System setup' to take a look at your options).

  • In a few cases, a Software or Hardware block can be preventing the Wifi from connecting. You can check for this by typing rfkill list into the terminal.

If you are still experiencing issues, there is a good troubleshooting guide here: https://help.ubuntu.com/stable/ubuntu-help/net-wireless-troubleshooting.html.en

@toadjamb's answer is for 16.04, and it shouldn't be necessary to download the driver for 18.04 in this manner as the driver is in the official Ubuntu repositories now.

  • thanks! just removed secure boot from bios and it did work fine! (thinkpad e480) – LEo Dec 5 '18 at 15:06

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.