0

The last few lines from /var/log/auth.log:

Jan  9 22:59:57 miranda-OptiPlex-790 lightdm: PAM adding faulty module: pam_kwallet5.so
Jan  9 22:59:57 miranda-OptiPlex-790 lightdm: pam_succeed_if(lightdm:auth): requirement "user ingroup nopasswdlogin" not met by user "miranda"
Jan  9 23:00:23 miranda-OptiPlex-790 dbus[807]: [system] Failed to activate service 'org.bluez': timed out

I was trying to add a new variable to system enviroment. I added one line to /etc/enviroment. Now I have sshed to the machine and removed the line. It looks like this now:

PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"

But I still can't login.

Guest Session works with no problem.

My problem is similar to this one: https://serverfault.com/questions/380917/cant-log-in-locally-but-ssh-works

He end up reinstalling the OS, I hope there is a still a way to save mine...

There is also another post about a similar problem: https://www.linuxquestions.org/questions/linux-general-1/can%27t-login-over-console-but-can-ssh-in-740310/

But the link to solution doesn't work anymore.


Tried suggestions here: cannot login into locked Ubuntu 14.04 session Unity

After reinstalling a bunch of things:

apt-get install --reinstall kwalletmanager
apt-get install libpam-kwallet4 libpam-kwallet5
service lightdm restart

The new auth.log shows:

Jan 10 00:05:10 miranda-OptiPlex-790 lightdm: pam_unix(lightdm:session): session opened for user miranda by (uid=0)
Jan 10 00:05:10 miranda-OptiPlex-790 systemd-logind[796]: New session c32 of user miranda.
Jan 10 00:05:10 miranda-OptiPlex-790 lightdm: pam_kwallet(lightdm:session): pam_kwallet: pam_sm_open_session
Jan 10 00:05:10 miranda-OptiPlex-790 lightdm: pam_kwallet(lightdm:session): pam_kwallet: final socket path: /tmp/kwallet_miranda.socket
Jan 10 00:05:10 miranda-OptiPlex-790 lightdm: pam_kwallet(lightdm:session): pam_kwallet: Impossible to write walletKey to walletPipe
Jan 10 00:05:10 miranda-OptiPlex-790 lightdm: pam_kwallet5(lightdm:session): pam_kwallet5: pam_sm_open_session
Jan 10 00:05:10 miranda-OptiPlex-790 lightdm: pam_kwallet5(lightdm:session): pam_kwallet5: final socket path: /tmp/kwallet5_miranda.socket
Jan 10 00:05:11 miranda-OptiPlex-790 lightdm: pam_kwallet(lightdm-greeter:setcred): (null): pam_sm_setcred
Jan 10 00:05:11 miranda-OptiPlex-790 lightdm: pam_kwallet5(lightdm-greeter:setcred): (null): pam_sm_setcred
Jan 10 00:05:11 miranda-OptiPlex-790 lightdm: pam_unix(lightdm-greeter:session): session opened for user lightdm by (uid=0)
Jan 10 00:05:11 miranda-OptiPlex-790 systemd-logind[796]: New session c33 of user lightdm.
Jan 10 00:05:11 miranda-OptiPlex-790 lightdm: pam_kwallet(lightdm-greeter:session): (null): pam_sm_open_session
Jan 10 00:05:11 miranda-OptiPlex-790 lightdm: pam_kwallet(lightdm-greeter:session): pam_kwallet: open_session called without kwallet_key
Jan 10 00:05:11 miranda-OptiPlex-790 lightdm: pam_kwallet5(lightdm-greeter:session): (null): pam_sm_open_session
Jan 10 00:05:11 miranda-OptiPlex-790 lightdm: pam_kwallet5(lightdm-greeter:session): pam_kwallet5: open_session called without kwallet5_key
Jan 10 00:05:11 miranda-OptiPlex-790 lightdm: pam_succeed_if(lightdm:auth): requirement "user ingroup nopasswdlogin" not met by user "miranda"
Jan 10 00:05:22 miranda-OptiPlex-790 dbus[807]: [system] Failed to activate service 'org.bluez': timed out

I'm not sure how to change the lightdm configuration

root@miranda-OptiPlex-790:/etc/lightdm/lightdm.conf.d# ls
root@miranda-OptiPlex-790:/etc/lightdm/lightdm.conf.d# cd ..
root@miranda-OptiPlex-790:/etc/lightdm# ls
lightdm.conf.d  users.conf
root@miranda-OptiPlex-790:/etc/lightdm# cat users.conf
#
# User accounts configuration
#
# NOTE: If you have AccountsService installed on your system, then LightDM will
# use this instead and these settings will be ignored
#
# minimum-uid = Minimum UID required to be shown in greeter
# hidden-users = Users that are not shown to the user
# hidden-shells = Shells that indicate a user cannot login
#
[UserList]
minimum-uid=500
hidden-users=nobody nobody4 noaccess
hidden-shells=/bin/false /usr/sbin/nologin

Should I try this solution? https://unix.stackexchange.com/questions/337697/pbis-auth-log-requirement-user-ingroup-nopasswdlogin-not-met-by-user-administ

Edit /etc/pam.d/lightdm and remove nopasswdlogin from this line:

auth    sufficient      pam_succeed_if.so user ingroup nopasswdlogin

migrated from serverfault.com Jan 10 '18 at 5:22

This question came from our site for system and network administrators.

  • 2
    requirement "user ingroup nopasswdlogin" not met by user "miranda" is a dead giveaway. Either add your user to that group or remove the directive from your lightdm config. – Gerald Schneider Jan 9 '18 at 13:19
  • I'm a bit cautious to change stuff I don't understand now, as I'm too scared that a wrong move may lock myself out completely. Could u plz give me more instructions? – Miranda Jan 9 '18 at 14:11
2

In the end the method here saved the day: https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/964607

I googled a bit to find out how to do it: https://askubuntu.com/questions/300682/what-is-the-xauthority-file

The exact steps:

Ctrl+Alt+F1 when I'm in the login screen.

chown miranda:miranda .Xauthority

Ctrl+Alt+F7

Some Explaination:

change miranda to your username.

Ctrl+Alt+F1 to F6 are the virtual consoles provided by the getty/agetty programs. Ctrl+Alt+F7 is the console where your X server is running. https://askubuntu.com/questions/157617/reverting-from-ctrl-alt-f1

Use ls -la .Xauthority to confirm if that is the problem.

  • I needed chown -R username:username ~username to resolve things – Eugene Gr. Philippov Apr 21 at 6:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.