0

I tried installing Google-Chrome-Stable on Ubuntu 16.04 from the graphical interface following instructions on https://www.linuxbabe.com/ubuntu/install-google-chrome-ubuntu-16-04-lts ... but it hung (waiting to install). Next I tried using terminal commands as per instructions but also failed. So I tried purging/removing all Google-Chrome-Stable files and got this:

(my-user-name)@(DELL)Inspiron-3451:~$ sudo apt-get purge google-chrome-stable
E: Type 'wget' is not known on line 44 in source list /etc/apt/sources.list
E: The list of sources could not be read.

Also a "no entry" icon appears on my laptop tool bar. How do I purge all the Google-Chrome-Stable files in this situation?

I considered reinstalling Ubuntu 16.04 but cannot boot from flash drive (no CD on laptop) because I had fiddled with BIOS settings to boot from flash drive to upgrade from Ubuntu 14.04. F2 and F12 for boot options no longer appear now when I start computer; it apparently boots direct from Ubuntu. I had finally managed to upgrade to 16.04 using 'About This Computer' interface after missing dependencies were installed.

I have limited skills using terminal commands and usually only follow instructions as I find them in Ubuntu websites. Please help me out.

Thank you very much.

marked as duplicate by karel, muru, Reinstate Monica - M. Schröder, Charles Green, user68186 Feb 8 '18 at 14:04

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • You made a mistake on the last instruction. Remove the 'wget' line from your sources.list. It doesn't belong there. – user535733 Jan 10 '18 at 4:17
  • @user535733 Thank you but without specific instructions on how to 'Remove the 'wget' line from your sources.list' I am not sure I understood what I am supposed to do... but I tried going through Google-chrome-stable installation again anyway, trying to apply your advice and it fails. I would prefer to purge all Google-chrome-stable files but various attempts did not work. – John Wong Jan 10 '18 at 17:21
  • Look up how to properly edit your file /etc/apt/sources.list. Find the line in that file with 'wget' in it (you put it on Line 44). Delete that line. Save the file. Then, and only then, can you begin the process of removing Chrome. As you have discovered, you won't be able to install or remove any deb packages until you fix that critical file. – user535733 Jan 10 '18 at 18:13
  • When putting terminal output into a question or answer, please paste it, select it with your mouse, and press the {} button in the editor. – Chai T. Rex Jan 11 '18 at 0:37
1

That guide is a bad one, since Chrome's .deb file handles all that setup for you and even does it properly (like using a file in /etc/apt/sources.list.d rather than polluting /etc/apt/sources.list).

First, undo the damage

  1. Open a terminal by pressing Ctrl+Alt+T
  2. Open the messed up file for editing by running:

    sudo nano /etc/apt/sources.list
    
  3. Remove the lines you added, which should be:

    deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
    wget https://dl.google.com/linux/linux_signing_key.pub
    
  4. Press Ctrl+O to save
  5. Press Ctrl+X to exit
  6. Check for errors in the Apt sources by running:

    sudo apt-get update
    
  7. If you get any errors, let me know by commenting below this answer

You can then install Chrome much more simply

  1. Open a terminal by pressing Ctrl+Alt+T
  2. Download the installer by running:

    wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
    
  3. Install Chrome by running:

    sudo apt-get install ./google-chrome-stable_current_amd64.deb
    
  4. Delete the installer by running:

    rm google-chrome-stable_current_amd64.deb
    
  5. Start up Chrome to make sure it installed properly by running:

    google-chrome & exit
    
  • @user535733 SOLVED: Google-chrome-stable installed and functioning; red icon no longer appears in browser tool bar. I had tried following the advice on this thread and then other threads concerning removal of red icon. I am not sure which instruction was finally effective but in the end when I used the Terminal to update and after restarted my computer, everything was back to normal. – John Wong Jan 20 '18 at 7:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.