22

I'm trying to add a new network printer on ubuntu 16.04 LTS. After setting it's IP address it recognises that a printer is available (192.168.1.100/9100), but when I click Forward I get a CUPS server error: 'server-error-internal-error'. Can anyone help?

The printer is connected to the router and is accessible from another Windows machine.

2
  • 2
    This isn't an answer but, when you run into this, look at /var/log/cups/error_log for a real error message.
    – LarrikJ
    Mar 22, 2019 at 20:22
  • @LarrikJ I did not find a useful error there unfortunately.
    – NoBugs
    Jul 16, 2020 at 4:17

1 Answer 1

27

I was able to work around the problem by setting up the printer using the CUPS web interface. I pointed my browser at localhost:631, which gave me the web interface. Then selected "Adding Printers and Classes", then "Add Printer".

It had already detected my network attached printer so it was just a matter of installing the correct PPD file from the selection.

I don't know why attempting to install the printer through the ubuntu Printers settings resulted in the 'server-error-internal-error', but this method seems to have worked fine. If anyone knows what the root cause of the error is I'd still love to know...

8
  • I click on Adding Printers and Classes in localhost:631 but I get Not Found error
    – silwar
    Dec 4, 2018 at 5:47
  • Exactly same issue for me under Fedora 28.
    – newandlost
    Apr 2, 2019 at 14:52
  • 4
    I had the same issue with my Xubuntu 18.04 and this workaround helped
    – Max
    May 5, 2019 at 20:32
  • Yes but why must you use this instead of the normal printer interface? Is this only for old printers?
    – NoBugs
    Jul 16, 2020 at 4:16
  • This workaround worked for me with a Canon Pixma MX455 and an Ubuntu 18.04 based distribution (although I had to use Firefox instead of Chrome to avoid an "Unauthorized" error when trying to add the printer through the CUPS web interface), after having installed the Linux drivers from the Canon site. The original issue seems to be related to a problem in CUPS, possibly with version 2.2.7, it seems like newer versions should work correctly.
    – Stephen G
    Mar 2, 2021 at 12:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .