33

Today I got what I presume was the update that should take care of Spectre and Meltdown. That didn't go very well. What do I do now? See screen photo.

enter image description here

I can't boot the 4.4.0-108-generic kernel because of a kernel panic. I'm running 16.04 on an Intel Core i5-4670K CPU @ 3.40GHz × 4.

33

Do not install 4.4.0-108-generic on Xenial! It breaks boot/reboot/shutdown/suspend functionality!

Install 4.4.0-109-generic (see USN-3522-3 for details)!


Reboot to the last working kernel and remove 4.4.0-108-generic:

  1. Press Shift between UEFI/BIOS and login-screen to enter GRUB
  2. In GRUB select Advanced options for Ubuntu and select Ubuntu, with Linux 4.4.0-xxx-generic (where xxx < 108)
  3. Login to the system and remove this buggy 4.4.0-108-generic and install 4.4.0-104-generic instead.

    sudo apt-get purge linux-headers-4.4.0-108 linux-headers-4.4.0-108-generic \
    linux-image-4.4.0-108-generic linux-image-extra-4.4.0-108-generic \
    linux-tools-4.4.0-108 linux-tools-4.4.0-108-generic
    sudo apt-get autoremove
    sudo apt-get install linux-headers-4.4.0-104 linux-headers-4.4.0-104-generic \
    linux-image-4.4.0-104-generic linux-image-extra-4.4.0-104-generic \
    linux-tools-4.4.0-104 linux-tools-4.4.0-104-generic
    

As of 2018-01-10 18:00 UTC, the 4.4.0-109-generic kernel seems to be distributed on mirrors.

But if you want you can select Main server (http://archive.ubuntu.com/ubuntu).
You can switch to it from software-properties-gtk / software-properties-kde.

You can install 4.4.0-109-generic with the following commands:

sudo apt-get update
sudo apt-get install linux-headers-4.4.0-109 linux-headers-4.4.0-109-generic \
linux-headers-generic linux-image-4.4.0-109-generic \
linux-image-extra-4.4.0-109-generic linux-image-generic \
linux-tools-4.4.0-109 linux-tools-4.4.0-109-generic linux-tools-generic
  • When I run autoremove after purging the 4.4.0-108 it asks me to remove the 4.4.0-103 versions - is that what I want to do? – Janina Jan 10 '18 at 12:32
  • 1
    I had updates turned off after I read Mesa broke other peoples' systems on Jan 4, 2018; so never got 108. 109 appears to be there already though: linux-generic/xenial-updates,xenial-security 4.4.0.109.114 amd64 [upgradable from: 4.4.0.104.109] – WinEunuuchs2Unix Jan 10 '18 at 12:46
  • 1
    @Graham I updated my post. – N0rbert Jan 10 '18 at 13:47
  • 1
    Your instructions are to override boot and select 4.4.0-104--all good. Then purge version 4.4.0-108 that suffers a meltdown over meltdown fix--all good. Then install 4.4.0-104 but you just booted with it so why would you install it? What am I missing... – WinEunuuchs2Unix Jan 11 '18 at 0:01
  • 1
    The same thing happened to me couple of days ago. Followed the instruction here and it worked. However, today the 4.4.0-109 crashed, and even go back to 104 doesn't help. I have to manually fsck and have it fixed. Now I can login using 104. I probably will stick with 104 for now. – EXP0 Jan 18 '18 at 4:53
6

In your boot menu choose advanced options for ubuntu.

You can boot from an older kernel (that is still installed) there.

1

i cannot boot using 109 or 108 ubutnu VM on win 7 x64

see: https://stackoverflow.com/questions/48270285/not-able-to-boot-using-4-4-0-109-generic-or-108generic-ubuntu-vm

my question

i had to boot using 104

0

This fixed the issue for me:

  1. Using grub boot menu, boot older kernel version.
  2. Install even newer kernel

sudo apt install linux-generic-hwe-16.04-edge

update: looks like issue with version 4.4.0.108 fixed with version 4.4.0.109 released just now.

  • 1
    Many users do not need 4.13. It will be supported until middle of 2018. – N0rbert Jan 10 '18 at 12:45
-1

You can install the latest patch successfully if you boot with an older kernel (I went back about three releases) then run Ubuntu's all of Ubuntu's advanced options "system cleaning" tools including fsck. There apparently is something in the earlier releases that must be "fixed" before the patch can be installed successfully.

protected by Community Jan 10 '18 at 13:37

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.