I have tried this:

sudo apt-get install virtualbox-guest-dkms and enabling bidirectional shared clipboard.

VirtualBox 4.12 Shared clipboard not working in Ubuntu14.04

and various other things, now hard to collect, but nothing works so far.

How to fix it?


When trying to insert guest additions CD image, I get this error:

could not mount error

From this question, Unable to Install Guest Additions CD Image on Virtual Box, I tried:

installing virtualbox-guest-utils

Tried also:

sudo apt-get upgrade
sudo apt-get install virtualbox-guest-additions-iso and this gives:

already the newest version

Restarting the virtual machine did not help, no errors.

  • "Started working..." I am confused. I don't see this in the link you shared. Did you get this working or not?
    – Buck
    Jan 11, 2018 at 19:12
  • @Buck - oh, I have made mistake by copying. It is still not working, edited post.
    – Darius.V
    Jan 12, 2018 at 16:40
  • 1
    did you install the guest-additions into the guest OS?
    – ravery
    Jan 14, 2018 at 20:11
  • this one: sudo apt-get install virtualbox-guest-dkms ? I think I did
    – Darius.V
    Jan 14, 2018 at 20:17
  • 3
    Possible duplicate of VirtualBox 4.12 Shared clipboard not working in Ubuntu14.04
    – Fabby
    Aug 30, 2018 at 18:07

3 Answers 3


virtualbox-guest-dkms's version in Ubuntu 16.04.3 is 5.0.40-dfsg-0ubuntu1.16.04.2, which is the version of VirtualBox in Ubuntu's repository rather than 5.2.4. This might be causing your issue.

Try the following to install the proper version of Guest Additions:

  1. Start the virtual machine
  2. In the VirtualBox Devices menu, choose Insert Guest Additions CD image...
  3. Open a terminal by pressing Ctrl+Alt+T
  4. Run sudo apt purge virtualbox-guest-dkms
  5. Run sudo /media/$USER/VBox_GAs_5.2.4/VBoxLinuxAdditions.run
  6. Reboot

Except for step 4, it's a good idea to do this every time there's a new version of VirtualBox (step 5 should be changed to the proper path, of course).

  • Inserting guess additions gives error, updated the post.
    – Darius.V
    Jan 16, 2018 at 12:15
  • 1
    Fixed not being able to insert guest additions image by askubuntu.com/questions/573596/… Dave Rose answer. And now it works - thank you, you are genius! How do you know that? :) why I cannot find that information?
    – Darius.V
    Jan 16, 2018 at 15:12

I encountered the "shared clipboard" bug in 6.1.4 while running on a Windows host. I know that it is, indeed, a not-yet-unresolved bug in this version of VirtualBox.

As others have suggested, I found that I could bypass the problem by reinstalling version 6.1.2 of the Guest Additions. I found the necessary Windows installer by going to "Older builds 6.0" on the VirtualBox website, then manually editing the URL from 6_0 to 6_1.

Then, after installing the Windows side of things (VirtualBox very graciously understands the idea of "downgrade"), you of course must then mount the CD image, and run the Linux-side ".run" file as root. (Exactly as you must do with any Guest Additions release ...) Then, restart the VirtualBox application on the host, and boot the virtual machine. (You must thereby update the software on both sides.)

Of course this problem is actively being discussed on the VirtualBox web site and it is a known, confirmed problem. ("Zed, we have a bug!") I'm quite sure that 6.1.5 will have a permanent solution.


This is a bug in 6.1.4 discussed in the forum. The solution is to download and install VirtualBox Guest Additions 6.1.97 r136310 as mentioned in this comment. Or wait for the new release 6.1.5

  • Thank you!! This was driving me nuts. I uninstalled and installed 6.1.2 and now it works.
    – jongusmoe
    Mar 30, 2020 at 17:28
  • Thank you; installed 6.1.5 testbuild GuestAdditions and it worked like a charm Apr 1, 2020 at 21:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .