4

I managed to download an OpenVPN file from VPN Gate, imported it and connected it. The VPN was connected and my IP was changed, but I couldn't access certain page (which I believe is blocked by my ISP) as it would like when using my local wireless network. As far as I know a VPN should bypass any blocks by my ISP.

I tried, using DNS and direct IP address (also using both TCP and UDP method), but none of them works. I also tried connecting with both wireless and USB wired from my Android phone but none works, too. (wireless is tethered from Android phone)

Though, with same VPN configuration, I can reach the page with my phone.

I'm connected from a phone with LTE connection, and it's my only source of internet until this post edited.

Here is the output of ifconfig, route and traceroute google.com in order. I typed it when connected to VPN.

Output of ip route show (while connected to VPN) and resolv.conf file:

$ ip route show
default via 10.211.1.98 dev tun0  proto static  metric 50 
default via 192.168.43.1 dev wlo1  proto static  metric 600 
10.211.1.98 dev tun0  proto kernel  scope link  src 10.211.1.97  metric 50 
131.147.175.48 via 192.168.43.1 dev wlo1  proto static  metric 600 
169.254.0.0/16 dev wlo1  scope link  metric 1000 
192.168.43.0/24 dev wlo1  proto kernel  scope link  src 192.168.43.77  metric 600 
$ cat /etc/resolv.conf 
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1

How do I reach the blocked page, then?

6
  • Does the VPN also handle DNS requests for you? Or do you use your ISP's DNS despite connecting to the VPN? – Mukesh Sai Kumar Jan 13 '18 at 16:17
  • @MukeshSaiKumar I don't have an idea. I just use a quick setting of OpenVPN profile import. How do I figure that? – Aryo Adhi Jan 13 '18 at 16:19
  • Umm.. a quick and dirty workaround would be to manually set your DNS Servers to 8.8.8.8 and 8.8.4.4. Check here and update me. :) – Mukesh Sai Kumar Jan 13 '18 at 16:32
  • Please edit your post to include the output of traceroute, run like this: traceroute google.com. Likewise, please also include ifconfig and route. – Kaz Wolfe Jan 13 '18 at 16:42
  • Can you please edit your question to include the output of ip route show and cat /etc/resolv.conf? – vidarlo Jan 13 '18 at 17:11
2

A quick workaround suggested by Mukesh (referring to this question) is the current acceptable solution for me.

By changing IPv4 DNS servers on my local network (let it be, 8.8.8.8 and 8.8.4.4), it went through the blocked page (i.e Reddit) without any problem.

This is probably one of numerous applicable answers for me.

1
+50

The problem is really that the nameservers is not updated. They still point to your ISP's NS, and DNS is the common way of doing blocking.

Usually the VPN provider will push out a DNS server when connecting. To actually use these, you have to ask OpenVPN to change the system settings. Add the following lines to your OpenVPN config file:

up /etc/openvpn/update-resolv-conf
down /etc/openvpn/update-resolv-conf

This is a script that will update your resolv.conf automatically when connecting, and again when disconnecting.

The good news with DNS blocking is that you may not need a VPN. Try simply specifying different DNS servers, without connecting to a VPN, and see if that allows you to access blocked sites.

2
  • I don't see any place to input those commands. Or perhaps, I missed something? – Aryo Adhi Jan 14 '18 at 2:40
  • Ah! Sorry. I missed that you imported it. I'm not aware of any way to set scrpits in NM, but you can specify the DNS server on the IPv4 properties page of the VPN connection. Simply enter something like 8.8.8.8 – vidarlo Jan 14 '18 at 10:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.