0

This is a new occurrence of an old problem. I can not use USB connected drives or memory sticks.

This just started yesterday after a software update. I ran my backup software the same as usual, but it crashed.(Lucky Backup)

In checking, I saw that my EXT4 external drive no longer had me as the owner. I have no idea how the ownership was changed. I had created the single backup directory on this drive about 6 weeks previously.

Since the files on this drive were simple duplicates of the files on my hard drive, I deleted the EXT4 partition and created a NTFS partition on the backup drive.

Once more I did a backup, and once more it crashed.

As a test, I tried to copy 20 GB of photos to a FAT32 memory stick with 32 GB of empty space. This also crashed.

I ran a memory test for an hour and found no errors.

Unsure of relevance, but the log shows continuous errors by LIRC.

Using Ubuntu Gnome 17.10.

This has also been posted on Facebook.

Drive Permissions

Basic Drive properties.

1 Answer 1

0

open up a terminal and try running this command , assuming you have sudo permissions :

sudo chown -R <username> /media/lloyd/<nameofyour drive>

(It asks for your password)

some drives are mounted on /mnt you need to check for that though

And I would not recommend formatting your external hdds to EXT4

5
  • I am mainly trying to figure out why the permissions changed.
    – lloyd
    Jan 8, 2018 at 19:27
  • Also. while it seems that USB transfers are still working, they have been drastically slowed down. Example: I transferred 7 GB of data to a 32 GB Memory stick last night. It took 1 hour. I transferred the same data from my memory stick to my Windows 7 computer today. (Which I consider to be dead slow) It took less than 10 minutes to transfer using Windows. Something has suddenly become seriously wrong. A memory check did not show any errors in my computer memory.
    – lloyd
    Jan 8, 2018 at 19:33
  • Check out the answer for this post , EXT4 for external hard disks will create problems , since you have re installed your systems your UID/GID s would have changed , hence the read only the link to the post below:: askubuntu.com/questions/579793/…
    – ajax_velu
    Jan 9, 2018 at 1:24
  • System seems to be fixed. But I doubt that I had anything to do with it. I un-installed a few programs which I suspected. Several programs including "Fakeroot."I was told on Facebook that I needed that, so I reinstalled it, along with "Fakeroot-ng”, and added a couple programs that I thought might help. External drive was re-formatted to NTFS format. Received message that a new release version of 17.10 was due to be released on Jan 10th. I updated Jan 10th. The computer seems to be back to normal today. But I doubt anything that I did fixed things. Suspect update as the fix.
    – lloyd
    Jan 11, 2018 at 23:27
  • This was an internal 2nd drive. Sorry, but the comment about EXT4 external drives was not relevant, although I have tried to use an external EXT4 drive in the past.
    – lloyd
    Feb 4, 2018 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.